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IBM Aspera Drive 3.2 Admin Guide for MacOS

Welcome to the Drive documentation, where you can find information about how to install, maintain, and
use Drive.
Getting started
Introduction
IBM Aspera Drive is a data transfer client application that you run on your desktop or mobile device, to
move files or folders quickly and securely through your Aspera transfer server.
Installing Drive
To install Drive for the first time, follow the instructions in this section.
Common tasks
Drive with Aspera on Cloud
You can use Drive in conjunction with IBM Aspera on Cloud, a SaaS platform for file transfer and
collaboration.
Drive with Faspex
Drive with Shares
IBM Aspera Shares is a multinode web transfer application that enables organizations to share content
with internal and external users.
Drive with High-Speed Transfer Server
Aspera High-Speed Transfer Server (HST Server) is the foundation under Drive transfers with Faspex and
Shares, and under Drive transfers with AoC if your AoC uses an on-premises (tethered) transfer node.
Therefore, in any of these cases, the configuration of your HST Server is fundamental to your Drive
implementation.
Troubleshooting and support
Troubleshooting

Introduction
IBM Aspera Drive is a data transfer client application that you run on your desktop or mobile device, to
move files or folders quickly and securely through your Aspera transfer server.

Features at a Glance

When Drive is connected to the IBM Aspera on Cloud SaaS platform, you can perform the following tasks:

• Browse the contents of an Aspera on Cloud workspace from the file browser.
• Transfer files and packages from within the same browser view.
• Synchronize local folders with folders on the transfer server, in both directions.

Note: You cannot synchronize with an Aspera on Cloud folder if it resides on an AoCts (Aspera on Cloud
transfer service) node. For AoCts nodes, sync is not supported.

When Drive is connected to an IBM Aspera Faspex transfer server, you can perform the following tasks:

• Send packages to Faspex users and workgroups.
• Automatically download packages as they are received.
• See into Faspex packages from within the file browser.

When Drive is connected to an IBM Aspera Shares transfer server, you can perform the following tasks:

• Browse and manage the file systems on the transfer server.
• Transfer files and folders to and from the transfer server.
• Synchronize local folders with folders on the transfer server, in both directions.
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Basic System Architecture

Drive is installed on the user's workstation, for any number of workstations in your team's environment.

Drive works with an Aspera web application. In complex environments, it is possible to use more than one
of these (for example, both AoC and Faspex).

The HST Server underlies most implementations, and performs the “heavy lifting” of the data transfer.
(With Aspera on Cloud, your actual transfers may be performed by cloud infrastructure, rather than by a
physical server.)

Installation

Installing Drive
To install Drive for the first time, follow the instructions in this section.

About this task

To upgrade an existing Drive installation, see “Upgrading Drive” on page 3.

Before installing Drive, obtain (from your system administrator) the URL and username/password
credentials for at least one Aspera transfer server that you will use with Drive.

Procedure

1. Download and open the Drive disk image:

AsperaDrive-version.dmg

The Drive application appears in a Finder window.
2. Drag-and-drop the Drive application to the desired location (such as the desktop or the Applications

folder).
3. Launch Drive.

Go to where you placed the application and double-click it.
A wizard opens, for adding an account for use with an Aspera transfer server.

4. Use the Account Wizard to create an account for use with an Aspera transfer server.
See the section that best matches your environment:

• Adding a Drive Account for IBM Aspera on Cloud
• Adding a Drive Account for IBM Aspera Faspex
• Adding a Drive Account for IBM Aspera Shares
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• Adding a Drive Account for Cloud Storage
5. Enable the extensions that provide some Drive functions from the Finder interface.

a) From the Apple menu, select System Preferences.
b) Go to Extensions > All.
c) Ensure that for Aspera Drive, the Share Menu extension is enabled.

Upgrading Drive
To upgrade an existing Drive installation, follow the instructions in this section.

Procedure

1. Check the release notes for information on new features and fixes since your last installation.
2. While Drive is running, click the Drive icon  in the menu bar, and select Check for Updates.
3. If a newer release is available, click Install Update and follow the onscreen instructions to upgrade

your Drive installation.

Note: Before the upgrade can be applied, you must quit Drive.

Uninstalling Drive
To remove the Drive application from your system, follow the instructions in this section.

About this task

To remove the Drive application from your system, run the uninstallation script:

1. Open a terminal window:

Applications > Utilities > Terminal
2. At the terminal prompt, type the following command:

$ /installationDirectory/Aspera\ Drive.app/Contents/Resources/uninstall_drive.sh

installationDirectory is the folder where you placed the Drive application when you installed it. For
example, /Users/yourUserName/Desktop or /Applications.

3. Answer the prompts and finish the uninstallation process.

Working with IBM Aspera on Cloud

Drive with Aspera on Cloud
You can use Drive in conjunction with IBM Aspera on Cloud, a SaaS platform for file transfer and
collaboration.

When Aspera on Cloud is integrated into Drive, you can do the following:

• See all your Aspera on Cloud workspaces, files, and packages (sent, received, and archived) in a single
view in the file browser.

• Share content with members of your organization.
• Send packages to an Aspera on Cloud inbox.

Note: Drive does not currently support adding metadata to packages that it sends. Therefore, ensure that
Aspera on Cloud is not configured to have any required metadata fields when sending packages. You can
configure optional metadata fields, but Drive will ignore them.

Seeing into Your Aspera on Cloud Workspace

To view the contents of a location in Aspera on Cloud, you can use any of these interfaces:
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• Aspera on Cloud itself (in a web browser)
• Drive's Remote View

For detailed information on using Aspera on Cloud, see the Help Center within the Aspera on Cloud
application.

Adding a Drive Account for Aspera on Cloud
Use Drive's account wizard to configure a new AoC transfer account.

Before you begin

Have the following information available before configuring an account:

• Your organization name in Aspera on Cloud.
• The username and password that you have on Aspera on Cloud.

The steps below assume that you have Drive installed and running.

To add an Aspera on Cloud account to Drive, do the following:

Procedure

1. If the Account Wizard is not open, launch it:
In the menu bar, click the Drive icon  and select Preferences > Accounts. Then click  to add a
Drive account.

2. Select your IBM Aspera product:
Click IBM Aspera on Cloud.

3. Select your organization:
In Aspera on Cloud, the organization is the primary administrative container.
Either

• Enter your IBMid or email address, so that Drive can find your organization for you.

or
• Enter your organization URL.

4. In the new window that opens, sign in to Aspera on Cloud.
5. Set up content synchronization:

On the Sync Setup screen, either

• Set up syncing now.

To do so, either accept the default folder shown for Place my files in, or click Change to browse for
a different folder (or create a new one).

By default, the sync folder is created inside your Documents folder, in a folder with the name you
gave for the account in an earlier step. If you choose to use the default folder, it is created
automatically.

or
• Set up syncing later.

To do so, click I'd rather not set up file syncing now.
6. If you opted to set up syncing on the previous screen, the Account Wizard prompts you to choose

folders to sync.
You can either

• Select Synchronize with the selected remote folders and then select the folders on Aspera on
Cloud to sync.
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Click the arrows to expand or collapse the folder view, and select the check boxes for the folders
you want to sync.

Choose the sync direction:

– Two-Way
– Remote to Local (default)
– Local to Remote

Note: For a detailed explanation of your options for sync direction, see “Understanding Sync” on
page 15.

or
• Select I'll choose the folders to sync later.

7. Set up package downloading:

• Choose Automatically download my packages to and enter or browse to a location where you'd
like to store your downloaded packages.

or
• Choose I'd rather not set up automatic downloading now. You can change this setting later if

you wish.
8. If you opted to set up package downloading in the previous step, now select a timeframe:

• Choose to download packages from a date in the past.

Select Download my packages from date sent and choose an option from the drop-down:

– Yesterday (default)
– A week ago
– A month ago
– The beginning of time

or
• Choose to download packages from now on.

9. Set up how you will check for new packages:

• Automatically

Select Check for new packages and select an automated time interval from the drop-down list.

or
• Manually

Select I'll check manually using the Check Now option.
10. Click Finish to complete your Aspera on Cloud account setup.

Working with IBM Aspera Faspex

Drive with Faspex
IBM Aspera Faspex is a file-exchange application built on IBM Aspera High-Speed Transfer Server as a
centralized transfer solution. With a Web-based GUI, Faspex offers advanced management options for
FASP high-speed transfer to match your organization's workflow.

When working with Faspex, you can perform the following tasks:

• Send packages.
• Receive packages.

Before configuring Faspex to work with Drive, you need the following:
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• A computer running the correct version of Faspex. For instructions on how to install Faspex, see the IBM
Aspera Faspex documentation.

• Credentials for Faspex user accounts. Users will use these accounts in Drive to connect to Faspex.

Configuring Faspex
To install and configure Faspex, follow the instructions in the IBM Aspera Faspex Admin Guide.

Note: Drive does not currently support adding metadata to packages that it sends. Therefore, ensure that
Faspex is not configured to have any required metadata fields when sending packages. You can configure
optional metadata fields, but Drive will ignore them.

Adding a Drive Account for Faspex
Use Drive's account wizard to configure a new package transfer account.

Before you begin

Have the following information available before configuring an account:

• The address of the server where Faspex is installed and running.
• The username and password that you have on the Faspex server.

The steps below assume that you have Drive installed and running.

To add a Faspex account to Drive, do the following:

Procedure

1. If the Account Wizard is not open, launch it:
In the menu bar, click the Drive icon  and select Preferences > Accounts. Then click  to add a
Drive account.

2. Select your IBM Aspera product:
Click IBM Aspera Faspex.

3. Fill in the fields with the following information about the Faspex transfer server:

Account name A name for the account. The name is used only by Drive.

Server address The URL for the server that is running Faspex.

Click Next.
4. Select your Faspex server's authentication method:

Either

• SAML Authentication

If you choose SAML Authentication, log in to the Faspex server with this user's SAML credentials.

or
• Basic Authentication

If you choose Basic Authentication, enter the username and password that this user has on the
Faspex server.

5. If you are prompted to confirm the server's security certificate, indicate whether you trust the server.
6. Set up package downloading:

• Choose Automatically download my packages to the following directory and enter or browse to
a location where you'd like to store your downloaded Faspex packages.

or
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• Choose I'd rather not set up automatic downloading now. You can change this setting later if you
wish.

7. If you opted to set up package downloading in the previous step, now select a timeframe:

• Choose to download packages from a date in the past.

Select Download my packages from date sent and choose an option from the drop-down:

– Yesterday (default)
– A week ago
– A month ago
– The beginning of time

or
• Choose to download packages from now on.

Click Next.
8. Set up how you will check for new packages:

• Automatically

Select Check for new packages and select an automated time interval from the drop-down list.

or
• Manually

Select I'll check manually using the Check Now option.
9. Click Finish to complete your Faspex account setup.

Modifying Your Package Download Settings

About this task
You can modify the following aspects of a package transfer account:

• The local destination folder for downloading received packages.
• How often Drive should look for new packages.
• Whether to overwrite packages that have the same title.
• Whether to automatically decrypt downloaded packages.

The steps below assume that you have Drive installed and running, and that you have created at least one
Drive account that you want to modify.

Procedure

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Account name The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL
certificate.
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Field Description

Select this option if your server's certificate is not valid, but you trust the
server.

4. On the Services pane, click Packages: Settings.
The Packages dialog appears.

5. Modify the fields as needed:

Field Description

Download received packages
to

Specify the folder where downloaded packages will be saved.

You can download packages to the default folder: /Users/
macUsername/Documents/driveAccountName, or you can click
Change to provide a different folder name.

Overwrite packages that have
the same title

When a received package has the same title as an existing package,
Drive can either reuse the same folder (overwriting the existing
package), or create a new folder for the received package.

If you select this check box, packages with the same name as an
already existing downloaded package will be downloaded into the
existing folder. If a file being downloaded has the same name as an
existing file, that file from the older package is overwritten.

If you do not select this check box, Drive will create a new folder
for the new package, so that the existing one is not overwritten.

For example, if you have already downloaded a package with a title
of My_Files, and then download another package with the same
title, the files will be placed in My_Files(2).

If you select this check box, Drive will place the new package into
the existing My_Files folder instead of creating a new My_Files(2)
folder. If My_Files already contains a file with the same filename,
the existing file will be overwritten.

By default, this check box is not selected.

Do not download packages
sent by me

If this field is selected, packages that you send to yourself or to
work groups that you belong to are not downloaded. (By default, it
is selected.)

If this field is not selected, packages that you send to yourself or to
work groups that you belong to are downloaded.

Packages are downloaded
from

Note: This field is not
configurable.

Displays the date since which Drive will search for packages to
download.

For example, if this field displays 05/06/2014, Drive downloads
any packages that have arrived since May 6, 2014.

Check for new packages Select the interval in which to check for newly arrived packages.

Automatically unlock
encrypted files on download

If you have configured encryption for your packages, you can set
Drive to automatically decrypt them when they are downloaded. To
do so, select this checkbox and enter the decryption passphrase in
the Passphrase field.

6. Click OK to apply and save your settings, or click Cancel to cancel your selections.
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Sending Faspex Packages with Drive

Procedure

1. Open the Send Files dialog by doing one of the following:

• In the menu bar, click the Drive icon  and select Send To.
• In the Finder, right-click an item and select Send with Aspera Drive (or Services > Send with

Aspera Drive, depending on your Mac configuration).
2. In the Send Files dialog, enter the following:

Field or Button Description

Account The account you will use to send the package from (required).

Email or Group The recipient of the package (required).

Title A short, relevant title for the package (required).

Notes A short message to the recipient of this package.

Files A list of the files and folders in the package that will be sent.

To add items to this list, click Add files or drag and drop from the Finder into
the Send Files dialog.

Encrypt sent files Select this check box if you want to encrypt files before sending them. When
you select Encrypt sent files and click Send Package, you are prompted to
enter and confirm a passphrase.

When you send encrypted packages, you must provide the recipients with the
encryption passphrases so that they can decrypt packages after they receive
them.

Add files Click Add files to add a file or files to the package for transfer. You can also
drag and drop files from Finder into this dialog.

Add folder Click Add folder to add a folder to the package for transfer. You can also drag
and drop folders from Finder into this dialog.

Remove To remove an item from the package to be sent, select it in the Files list and
click Remove.

3. Click Send to send the package.

Results

The Drive Activity window's Transfers pane opens to display the progress of the transfer.

Receiving Faspex Packages with Drive

Procedure

• Getting More Information About a Transferred Package

a) In the menu bar, click the Drive icon  and select Activity.
b) Click Transfers to view a list of the recent packages that you have sent or downloaded.

c) With the buttons in the Transfers pane, you can perform the following additional tasks:

Opens the Transfer Monitor for more in-progress detail about the transfer.

In the Transfer Monitor, you can adjust the transfer rate (if settings allow).
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Opens a Finder window to the transfer destination folder (the "containing folder").

Stops an in-progress transfer.

Resumes a stopped or suspended transfer.

In addition to those actions, you can also right-click a package and select Remove to remove it
from the list.

• Clearing a Transfer
If a transfer is not currently queued or running, you can remove it from the list:
On the Transfers pane, right-click a transfer in the list and select Remove.

• Looking for New Packages
If you have configured Drive to look for new packages at a certain interval, click the Inbox pane to see
when Drive will next check for newly arrived packages.
You can also do the following:

– To stop checking for packages, click .

– To resume automatic checking for packages, click .
– To check for packages immediately, right-click an inbox and select Check Now.

• Decrypting Received Packages
If you receive an encrypted package, see “Decrypting Packages” on page 20.

Working with IBM Aspera Shares

Drive with Shares
IBM Aspera Shares is a multinode web transfer application that enables organizations to share content
with internal and external users.

Drive accounts that are set up with Shares as the transfer server provide the following functions:

• Users can transfer files and folders between their client computer and the server using the Finder file
browser interface, with the following standard Finder functions:

– drag-and-drop
– browsing files and folders
– transferring files to and from your transfer account
– creating new folders

• You can set up Drive to sync folders automatically on the client computer and on the server whenever
contents change. Content changes include

– modification of file contents
– changes in file and folder names
– creation and deletion of files and folders

The sync feature can be configured to be one-way or bidirectional.

For detailed information on Shares, including system requirements and installation instructions, see see
the IBM Aspera Shares documentation
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Configuring Shares

Before you begin

Before configuring Shares to work with Drive, you need the following:

• A computer running the correct version of Shares and Enterprise Server.
• On each node on the Shares server, a supported version of Connect Server with a Drive-enabled license.
• Credentials for your users' Shares accounts. Users will enter these account credentials in Drive, to

connect to Shares.

Note: If you will use the synchronization feature, you must ensure that the Enterprise Server is configured
to use token authentication.

Procedure

1. Log in to your Shares server as administrator, and go to Admin > Accounts > Users.
2. For each Shares user account that will use Drive, click Edit.
3. On the Security tab, ensure that the API Login check box is selected.

On Shares 1.6 and later versions, this permission is enabled by default whenever new users are
created.

4. Create shares, and authorize users for each share.
For detailed instructions on creating shares and authorizing users, see the IBM Aspera Shares
Administrator Guide.

5. For each authorized user of a share, enable the following permissions to allow users to view, edit, or
delete files and folders when using Drive:

In Order to Allow This Action on Drive... ...Enable This Check Box on Shares

View browse

download

Edit upload

mkdir

rename

Delete delete

6. For each Shares user account that will use Drive, repeat these steps.

What to do next
For more information on Shares, see the Shares Administrator Guide.

Adding a Drive Account for Shares
Use Drive's account wizard to configure a new Shares transfer account.

Before you begin

To set up a transfer account, make sure you have the following information from the system administrator
who manages your Shares transfer server:

• A URL for the Shares transfer server, including a port and path (if applicable).
• A username and password that was set up on your Shares transfer server.

The steps below assume that you have Drive installed and running.

To add a Shares account to Drive, do the following:
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Procedure

1. If the Account Wizard is not open, launch it:
In the menu bar, click the Drive icon  and select Preferences > Accounts. Then click  to add a
Drive account.

2. Select your IBM Aspera product:
Click IBM Aspera Shares.

3. Fill in the fields with the following information about the Shares transfer server:

Account name A name for the account. The name is used only by Drive.

Server address The URL for the server that is running Shares.

4. If you are prompted to confirm the server's security certificate, indicate whether you trust the server.
5. Select your Shares server's authentication method:

Either

• SAML Authentication

If you choose SAML Authentication, log in to the Shares server with this user's SAML credentials.

or
• Basic Authentication

If you choose Basic Authentication, enter the username and password that this user has on the
Shares server.

6. If the transfer server supports synchronization, either

• Set up syncing now.

To do so, either accept the default folder shown for Place my files in the following directory, or
click Change to browse for a different folder (or create a new one).

By default, the sync folder is created inside your Documents folder, in a folder with the name you
gave for the account in an earlier step. If you choose to use the default folder, it is created
automatically.

or
• Set up syncing later.

To do so, click I'd rather not set up file syncing now.
7. If you opted to set up syncing on the previous screen, the Account Wizard prompts you to choose

folders to sync.
You can either

• Select Synchronize with the selected remote folders and then select the folders on Aspera on
Cloud to sync.

Click the arrows to expand or collapse the folder view, and select the check boxes for the folders you
want to sync.

Choose the sync direction:

– Two-Way
– Remote to Local (default)
– Local to Remote

Note: For a detailed explanation of your options for sync direction, see “Understanding Sync” on
page 15.

or
• Select I'll choose the folders to sync later.
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8. When the screen displays a success message, click Finish to exit the Account Wizard.

Modifying a Drive Account for Shares

Before you begin

The steps below assume that you have Drive installed and running, and that you have created at least one
Drive account that you want to modify.

About this task

To modify a transfer account, do the following:

Procedure

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Account name The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the
server.

4. Back in the Preferences dialog, click Save to put into effect any changes you have made.

Transferring Content

About this task

Drive is accessible through a Finder-like interface. You can use standard Finder functions for moving and
copying files between the server and your local computer.

Procedure

1. To access the transfer server, click the Drive icon  in the menu bar, and select Aspera Drive >
accountName.

2. Use standard Finder functions for browsing through files and folders of each account, transferring files
to and from your transfer account, or creating new folders.

Note: Depending on your account's permissions on the file transfer server, you might encounter
limitations on the following actions on the transfer server:

• browsing
• transfers
• file operations
• context menu options

3. Verify the status of your transfer:
If it is not already open, open the Drive Activity window. On the Transfers pane, in the list of
transferred files and folders, view the status of your transfer.
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You can see its status during a transfer, or after it has completed.

The buttons on the Activity window's Transfers pane have the following meanings:

Opens the Transfer Monitor for more in-progress detail about the transfer.

In the Transfer Monitor, you can adjust the transfer rate (if allowed).

Opens a Finder window to the transfer destination folder (the containing folder).

Stops an in-progess transfer.

Resumes a stopped or suspended transfer.

Note: If a transfer is reported as complete but the file or folder does not appear in the Drive window,
refresh the window.

Working with IBM Aspera High-Speed Transfer Server

Drive with High-Speed Transfer Server
Aspera High-Speed Transfer Server (HST Server) is the foundation under Drive transfers with Faspex and
Shares, and under Drive transfers with AoC if your AoC uses an on-premises (tethered) transfer node.
Therefore, in any of these cases, the configuration of your HST Server is fundamental to your Drive
implementation.

For the most part, your HST Server does not need special configuration in order to work with Drive. You
configure your HST Server for use with Drive in the same way as you would for use with Aspera on Cloud,
Aspera Faspex, or Aspera Shares.

Setting Group Ownership

In some cases, you may want to control the permissions on files that are uploaded to a transfer server. To
do this, you can set the SGID bit on the directory on the transfer server into which files are transferred.

The steps below set the SGID bit on a directory named limited. When the steps are complete, transfers to
the limited directory will have group ownership rather than user ownership.

Note: The change in ownership applies to Drive transfers to this directory, and to files created in this
directory on the transfer server itself, but does not apply to transfers performed through sync actions.

1. Set the transfer server to ignore group ownership.

$ asconfigurator -x "set_node_data;group_ownership,-"

2. Change the group associated with the limited directory to mygroup. The group named mygroup is not
the user xfer's primary group.

$chgrp -R mygroup limited/

3. Set the SGID bit for the destination directory limited.

$chmod -R ug=rwx limited/
$chmod -R g+s limited/

4. Verify your changes.

$ ls -la limited/
drwxrwsr-x 1 root mygroup 1234 Apr 23 10:42 . 

Your output may vary, but ensure that the s is present in the group's permissions.
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Synchronization

Understanding Sync
If you are using IBM Aspera Drive with IBM Aspera on Cloud or IBM Aspera Shares, you can use Drive's
sync feature to automatically synchronize files and folders between the remote server and the local
computer.

Sync Direction

When you set up sync, you must choose the direction of synchronization. Drive can be configured for the
following direction settings:

• Remote to Local

This is the default setting. In this configuration, the remote computer (usually a server) retains the
master version of the files. The latest content is copied from the server to users' workstations.

• Local to Remote

In this configuration, the user's version of the content is assumed to be the master version, and is
copied to a central server. Typically, this setting is employed when users update content frequently.

• Two-Way

In a two-way, or bidirectional, sync relationship, changes in each location are copied to the other
location. With this type of sync, the contents of both remote and local are identical after the sync has
completed.

Note: When you have two-way sync configured, Drive runs these transfers using the lowest non-zero
bandwidth limit that you have set for for automatic transfers. For details on setting bandwidth limits for
automatic transfers, see “Manual Versus Automatic Transfers” on page 24.

If no bandwidth limit is set, Drive runs two-way sync transfers at the maximum rate that the server and
network conditions allow.

Avoiding Sync Conflicts

To avoid unexpected results, understand what each sync direction setting means and choose carefully.
For example, consider the following scenario:

The system is configured for remote-to-local sync. When the scheduled automatic sync occurs, the latest
content is copied from the remote computer to the user's local desktop. A local user then creates a new
file. The next automatic sync occurs, but this new file still exists only on the user's computer. This is the
expected behavior in remote-to-local sync. In this scenario, the content on the destination is not
necessarily identical to that on the source.

Initial Synchronization

When you first set up a sync relationship between two computers, the system performs its initial transfer
of content from the source location to the destination (or target) location. Depending on the size of the
content, this can be a large operation.

Then, when the system performs the next automatic sync, any changes at the source location are copied
to the target.

Automatic Sync Versus Reset

Automatic Sync

After the initial transfer, synchronization between the transfer server and client computers occurs
automatically, at the regular interval you have set in Drive's Preferences dialog.

In these automatic sync operations, the system transfers only the changes since the most recent sync.
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Reset Sync

A reset operation is like starting over. Unlike automatic sync, a reset is a wholesale transfer of all the
content, not just the changed content. Because a reset clears the sync records, you typically perform a
reset only after resolving a conflict or changing the sync configuration.

Sync with Aspera on Cloud
If you are using Aspera Drive with Aspera on Cloud, Drive can synchronize files and folders automatically
between the remote server and the local computer.

Note: You cannot synchronize with an Aspera on Cloud folder if it resides on an AoCts (Aspera on Cloud
transfer service) node. For AoCts nodes, sync is not supported. If you are not sure whether the node you
plan to use is an AoCts node, check with the AoC admin for your organization.

Before you begin, ensure that you have the following in place:

• Drive account configuration:

You must have Drive accounts that can synchronize content with your Aspera on Cloud organization.

For more information, see “Adding a Drive Account for Aspera on Cloud” on page 4.
• Sync configuration in Drive and in Aspera on Cloud:

Pay close attention to the configuration of the sync relationship. In all cases, the settings in Aspera on
Cloud override the settings locally in Drive. Note that if your Aspera on Cloud transfer server nodes are
not correctly configured, you may experience sync problems between Aspera on Cloud and Drive users.

For detailed information, see the IBM Aspera High-Speed Transfer Server documentation.

Sync with Aspera Shares
If you are using Aspera Drive with a Shares transfer server, Drive can synchronize files and folders
automatically between the remote server and the local computer.

Before you begin, ensure that you have the following in place:

• Server configuration:

In order to set up sync with a Shares server, the server must be configured for sync in its aspera.conf
file and must have the appropriate license.

For further information on your server's configuration file and license, see the Admin Guide for your
Shares transfer server.

• User permissions in Shares:

Shares users who will use Drive with sync features must be authorized to perform create, delete, and
rename file operations. The Shares admin can set these on the Authorizations tab.

• Drive account configuration:

You must have Drive accounts that can synchronize content with a Shares server.

For more information, see “Adding a Drive Account for Shares” on page 11.
• Sync configuration in Drive and in Shares:

Pay close attention to the configuration of the sync relationship. In all cases, the settings on the Shares
server override the settings locally in Drive. Note that if your Shares server is not correctly configured,
you may experience sync problems between the server and Drive users.

For detailed information, see the IBM Aspera High-Speed Transfer Server documentation.
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Configuring Sync in Drive
When you use Drive's synchronization capability, you can configure various aspects of the sync
relationship. Start by selecting Preferences > Accounts.

Selecting Folders to Sync

About this task
In most cases, you will have set up sync folders when you added accounts to Drive. But if you opted not to
set up sync with your accounts, or if you need to change the the folders on the transfer server that you
want the local computer to sync with, do the following:

Procedure

1. On the Accounts pane, select the account for which you want to configure sync folders.
2. On the Services pane, click Sync folder: Settings.

The Sync Settings dialog appears.

Note: If sync capabilities are made available for the transfer server after the account has been added
to Drive, you must remove and then re-add the account to Drive in order to use the Sync Settings
dialog.

3. Select the folders on the remote server that you would like to sync with the local computer.
Browse through the nested folders shown under Synchronize with the selected remote folders, and
select the ones that should be synced with.

4. Set the local path for the sync.
Under Local Folder Path, the default path on the local computer is shown. If you want to change it,
click Browse and navigate to the desired location.

Configuring the Sync Direction

About this task
Drive's synchronization between the remote server and the local computer can be upload-only,
download-only, or bidirectional. For a description of these sync direction options and their behavior, see
“Sync Direction” on page 15.

To set the sync direction, do the following:

Procedure

1. On the Accounts pane, select the account for which you want to configure sync direction.
2. On the Services pane, click Sync folder: Settings.

The Sync Settings dialog appears.

Note: If sync capabilities are made available for the transfer server after the account has been added
to Drive, you must remove and then re-add the account to Drive in order to use the Sync Settings
dialog.

3. In the Direction drop-down list, choose Two-Way, Remote to Local, or Local to Remote.

Resetting the Sync

About this task
You can reset the sync at any time; for example when you have changed the sync configuration, or after
resolving a sync conflict. When you reset the sync, your sync configuration settings are retained, but the
repositories are rescanned for discrepancies. To reset the sync, do the following:
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Procedure

1. On the Accounts pane, select the account for which you want to reset the sync.
2. On the Services pane, click Sync folder: Settings.

The Sync Settings dialog appears.

Note: If sync capabilities are made available for the transfer server after the account has been added
to Drive, you must remove and then re-add the account to Drive in order to use the Sync Settings
dialog.

3. Select Reset Sync and click OK.

Syncing Content

Monitoring Sync Status

You can monitor the status of a sync operation on the Activity Window > Sync tab.

A progress bar shows in-progress synchronizations, and a countdown timer shows when the next
synchronization will take place.

Stopping and Starting Sync

You can stop and resume file syncing with these buttons on the Activity Window > Sync tab:

Stops an in-progress synchronization.

Resumes a stopped synchronization.

Resolving Sync Conflicts

A sync conflict occurs when the file on one side does not match the file on the other side. Files and folders
may not be synchronized for reasons such as insufficient permissions for the destination folder on the
local computer.

If a file or folder cannot be synchronized, a conflict warning appears on the Activity Window > Sync tab.

To resolve the conflict, do the following:

1. Click the red conflict link.
2. In the dialog that appears, select the file or folder that is in a conflict state.
3. Click Resolve Selected Conflicts.

Drive renames the content on the local file system, appending the phrase conflict-mine. For example,
the file log.txt is renamed as log.conflict-mine.txt.

After resolving a sync conflict, you might need to reset the sync. For more information, see #unique_33/
unique_33_Connect_42_resetting_sync.

Working with Cloud Storage

Adding a Drive Account for Cloud Storage
Use Drive's account wizard to configure a transfer account for cloud storage.

Before you begin

To set up a transfer account, make sure you have the following information from the system administrator
who manages your transfer server:

• A URL for the transfer server, including a port and path (if applicable).
• A username and password that was set up on your transfer server.

18  IBM Aspera Drive 3.2



The steps below assume that you have Drive installed and running.

Procedure

1. Select your IBM Aspera product:
Click IBM Aspera on Cloud.

2. If the Account Wizard is not open, launch it:
In the menu bar, click the Drive icon  and select Preferences > Accounts. Then click  to add a
Drive account.

3. Fill in the fields with the following information about the transfer server:

Field Description

Account Name The name of the account. The name is used only by Drive.

Server Address The URL address for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Click Set up Aspera Drive.
4. Fill in the following information about your cloud storage:

Field Description

Cloud Storage The type of cloud storage. Select either Microsoft Azure or Microsoft
Azure SAS.

Storage account The account name for the cloud storage you will use.

Note: For Azure SAS accounts, the URL must have been created with full
permissions.

Access key The alphanumeric key for this storage account.

Path The path within the storage that this Drive account should have access
to.

Use page blobs Select if your cloud storage uses page blobs.

Click Next.
5. When the screen displays a success message, click Finish to exit the Account Wizard.

Modifying a Drive Account for Cloud Storage

Before you begin

The steps below assume that you have Drive installed and running, and that you have created at least one
Drive account that you want to modify.

About this task

To modify a cloud account, do the following:

Procedure

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:
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Field Description

Account name The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the
server.

4. In the Storage area, you can configure these aspects of the account:

Field Description

Storage account The account name for the cloud storage you will use.

Access key The alphanumeric key for this storage account.

Path The path within the storage that this Drive account should have access to.

If you make changes to these fields, Drive then verifies that it can still access the storage. If it cannot,
you can revert to the previous settings.

5. Click OK to put into effect any changes you have made.

Working with Aspera Encrypted Files

Decrypting Packages
Encrypting a file protects it from unwanted access. When an encrypted file arrives after transfer, you must
decrypt it before you can use it.

Note: Decrypting files requires a passphrase — a sequence of text that the sender of the package used to
encrypt the package. Before decrypting files, ensure that you have the necessary passphrase.

IBM Aspera Crypt works with Drive to decrypt downloaded files.

To decrypt files you have downloaded, do the following:

1. Go to Activity > Transfers and select the encrypted package you want to decrypt.

2. While Drive is running, click the Drive icon  in the menu bar, and select Unlock Encrypted Files.

The Aspera Crypt dialog appears.
3. Select a package or browse to the encrypted content.

When the encrypted content is loaded into Crypt, a status message appears at the bottom of the
application, displaying the number of items ready for decryption.

4. Type the passphrase into the field and click Decrypt.

You can also choose to decrypt the content later.
5. View the output in the Aspera Crypt viewing window.

The decrypted contents appear in the same directory as the original encrypted contents.

If the decrypted file (without the .aspera-env extension) already exists in the same folder,
“(decrypted)” is added to the filename.

If your Aspera Crypt viewing window has multiple decrypted items listed, you can use the View drop-
down list to sort the items by latest, finished, or failed.
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Automatic Decryption

As an alternative to the manual process above, you can set Drive to automatically decrypt the packages
that it downloads.

Choose one of the following ways to set up automatic decryption:

• When you create the Drive account for Faspex or Aspera on Cloud, select the option to Automatically
unlock encrypted files on download.

• Modify an existing account to enable this option. For instructions, see “Modifying Your Package
Download Settings” on page 7.

Configuring Your Decryption Settings

About this task
You can adjust the settings that are used when packages are decrypted. In the Crypt window, do the
following:

Procedure

1. Click Settings.
2. Configure the following:

• Delete encrypted files when finished

When this check box is selected, Crypt removes the encrypted files from your system after the
destination (decrypted) content has been created.

• Number of concurrent threads for decryption

Select the number of threads that are decrypting at any given time. A higher setting means that files
will be decrypted more quickly, but this may slow down the rest of your computer while it is
running. The options are 1 (default), 2, 4 and 8.

Drive Preferences

Setting Your Preferences in Drive
Through the Preferences dialog, you can set your preferences for the following areas:

• general settings
• accounts
• transfers
• network
• bandwidth

To set your preferences, open the Preferences dialog:

With Drive running, click its icon  in the menu bar, and select Preferences.

General Preferences
To set your general preferences for Drive, select Preferences > General.

You can set the following preferences in Preferences > General:

Field Description

Remove transfer list
items

Select whether to remove the entry automatically from the transfer view
after it has completed, or to manually remove items.
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Field Description

Manually is selected by default.

Logging level Choose the level of information to be recorded in the Drive logs. Options
are:

• Info
• Debug
• Trace

Note: Do not change this setting unless Aspera Technical Support asks you
to do so.

Account Preferences
To create, configure, modify, and remove Drive accounts, select Preferences > Accounts.

Adding an Account

• For instructions on adding Drive accounts for use with the Aspera on Cloud SaaS, see “Adding a Drive
Account for Aspera on Cloud” on page 4.

• For instructions on adding Drive accounts for use with a Shares transfer server, see “Adding a Drive
Account for Shares” on page 11.

• For instructions on adding Drive accounts for use with a Faspex transfer server, see “Adding a Drive
Account for Faspex” on page 6.

• For instructions on adding Drive accounts for use with cloud storage, see “Adding a Drive Account for
Cloud Storage” on page 18.

Removing an Account

To remove an account, do the following:

1. In the list of accounts, select an account to be removed.

2. Click  to remove the account.

When you remove an account, all account transfers and services associated with that account are
stopped and removed.

3. Click Yes to confirm the account removal, or click No to cancel the account removal.

Configuring Sync Settings

For Drive accounts that are set up with Aspera on Cloud or Shares as the transfer server, you can
configure synchronization settings, such as which remote folders to sync with, and the direction of the
synchronization relationship.

For instructions on setting up and using synchronization features, see “Sync with Aspera on Cloud” on
page 16 and “Sync with Aspera Shares” on page 16.

Configuring Package Settings

For Drive accounts that are set up with Aspera on Cloud or Faspex, you can configure the following:

• The local folder for received packages.
• Whether to overwrite packages.
• How often Drive should look for new packages.

For instructions, see “Modifying Your Package Download Settings” on page 7.

If you make any changes on the Accounts pane, click either Revert to undo them,or Save to put them
into effect.
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Transfer Preferences
To set your transfer preferences, select Preferences > Transfers.

Procedure

1. Configure settings in the Queue area of the Transfers pane:

Field Description Default
Setting

Enable queuing When this check box is selected, Drive limits the number of
concurrent transfers.

Note: When transfers are queued, you can start them manually
from the Activity > Transfers window.

Selected

Maximum concurrent
transfers

If Enable queuing is selected, you can enter a maximum
number of concurrent transfers in this field.

Any transfers above this value are queued and then started
once the number of concurrent transfers drops below the
specified value.

When queuing is not enabled, this field is not available.

3

2. Configure settings in the Retry area of the Transfers pane:

Field Description Default
Setting

Automatically retry
failed transfers

When this check box is selected, Drive retries failed transfers.

If you want Drive to retry failed transfers, specify the number
of attempts and the interval in which Drive will try to resend in
seconds, minutes, or hours.

Selected

Attempts When Automatically retry failed transfers is selected, Drive
will make the number of retry attempts that you specify in this
field.

3

Interval When Automatically retry failed transfers is selected, Drive
will retry transfers at the interval you specify in this field.

30
seconds

3. Configure settings in the Sync area of the Transfers pane:

Field Description Default
Setting

Interval If the sync feature is enabled, specify the interval between
synchronizations.

30
seconds

4. Close the Preferences dialog. Drive saves your settings.

Network Preferences
To set your network preferences, select Preferences > Network.

Procedure

1. In the HTTP Proxy area, set the following preferences:
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Field Description

Use HTTP Proxy If this check box is selected, Drive uses an HTTP proxy to connect to
the Internet.

• Username
• Password
• Address and Port

Use these fields to define your HTTP proxy configuration. Type the
following information:

• your username
• your password
• your server's URL or IP address, and port number

Note: For some proxies, username and password are optional.

2. If you will use a FASP proxy for your transfers, set the following preferences in the dialog's FASP Proxy
area:

Field Description

Use FASP Proxy (DNAT) If your transfers will use an IBM Aspera FASP Proxy server, select this
check box.

Secure (DNATS) Select this check box if your FASP Proxy uses a secure connection.

• Username
• Password
• Address and Port

Use these fields to define your FASP Proxy configuration. Type the
following information:

• your server username
• your server password
• your server's URL or IP address, and port number

Note: These fields are enabled only if Use FASP Proxy (DNAT) is
selected.

Bandwidth Preferences
Transfer speeds depend on server settings and your network connectivity. To limit transfer rates, go to
Preferences > Bandwidth.

Manual Versus Automatic Transfers

The limits you set on the Bandwidth tab can be different for transfers that are initiated manually versus
those that are automatically triggered. Automatic transfers can include sync-initiated transfers, script-
initiated transfers, or any other kind of background method of starting a Drive transfer.

Settings

Area Field Name Description

Manual Transfers Limit downloads to When the Limit downloads to check box is selected, you
can set the download rate in either megabits per second
(Mbps) or kilobits per second (Kbps).

The limit you set here will apply to downloads that users
initiate manually.

Limit uploads to When the Limit uploads to check box is selected, you can
set the upload rate in either megabits per second (Mbps)
or kilobits per second (Kbps).
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Area Field Name Description

The limit you set here will apply to uploads that users
initiate manually.

Automatic
Transfers

Limit background
downloads to

When the Limit background downloads to check box is
selected, you can set the download rate in either megabits
per second (Mbps) or kilobits per second (Kbps).

The limit you set here will apply to transfers that are
initiated for Inbox downloads or sync actions.

Limit background
uploads to

When the Limit background uploads to check box is
selected, you can set the upload rate in either megabits
per second (Mbps) or kilobits per second (Kbps).

The limit you set here will apply to transfers that are
initiated for sync actions.

Troubleshooting

Where do I find Drive log files?

In the menu bar, click the Drive icon  and select Open Log Folder.

Alternatively, you can go to ~/Library/Logs/Aspera_Drive.

How can I reduce the bandwidth that Drive uses?

You can limit the number of concurrent transfers in Preferences > Transfers. You can also limit the
amount of bandwidth used by each transfer in Preferences > Bandwidth. For details, see “Transfer
Preferences” on page 23 and “Bandwidth Preferences” on page 24.

The system sent me an email notifying me that I've received a package. Why can't I download the
package through my Web browser?

To download transferred packages through a Web browser, you must have the IBM Aspera Connect
application installed on your local computer.

Go to downloads.asperasoft.com/connect2/ and install Connect so that your browser can download
packages from the transfer server.

For more information, see the IBM Aspera Connect User's Guide.

I'm using Drive with a Shares server, but I don't see a way to configure my sync settings.

It may be that Drive needs to re-load sync information for that Shares server or node.

To address this, do the following:

1. Go to Preferences > Accounts.
2. Remove the account.
3. Add the account again so that Drive recognizes the sync capabilities.

The Services pane should now appear.

I'm using SAML authentication, and am having trouble logging in.

When you quit out of Drive and then restart, the system needs to re-authenticate you with the server. So
enter your SAML credentials again when you restart Drive.
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Syncing with multiple folders

When your Drive installation is configured with a local-to-remote sync, Drive does not recreate all
subfolders of the selected remote sync folder on the local computer. This is the default behavior,
intended to reduce confusion since you are not interacting with the subfolders.

If you want to sync into the subfolders, make sure to select them individually (effectively setting up
multiple sync relationships).

How can I view thumbnails of video files?

While you can see a preview of image files, and many other file types, in the file browser, Drive does not
support video previews.
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