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Release Notes: IBM Aspera Drive 3.1.3

Product Release: April 10, 2018
Release Notes Updated: June 19, 2018

NEW FEATURES

This release of IBM Aspera Drive updates the name of the web domain that Drive uses for Aspera Files. With the
introduction of the Aspera on Cloud product, the domain that Drive communicates with is now *.ibmaspera.com.

To test this change, Aspera recommends the following steps:

1. Create a new Drive account to use for testing.

Go to Aspera Drive > Preferences > Accounts and click the plus sign to add a new account.
2. In the Account Wizard's Address field, type your Files or Aspera on Cloud URL, with the new domain.

For example: https://myCompanyName.ibmaspera.com
3. Perform a transfer (upload, download, or sync) with this new account.

If you encounter errors, contact Aspera Technical Support.

SYSTEM REQUIREMENTS

On your Aspera Drive client:

One of the following:

• Mac: Mac OS X 10.11, 10.12, or 10.13.

Note:  For Drive with Aspera Files, installation requires a Mac admin account on the client computer.
• Windows: Windows 7 with Service Pack 1 and IE 11; Windows 8; or Windows 10.

On your transfer server:

One of the following:

• Aspera Shares 1.8.1 or higher, with Aspera Enterprise/Connect Server 3.5.x or higher with a Drive-enabled license
• Aspera Faspex 3.8.1 or higher, with Aspera Enterprise/Connect Server 3.5.x or higher with a Drive-enabled

license
• Aspera Enterprise/Connect Server 3.5.x or higher with a Drive-enabled license

Note:  For the checkin/checkout feature with Files, your transfer server must be of version 3.7.3 or higher.

Note:  For the synchronization feature, you must have Aspera Enterprise Server 3.5.x or higher with a Sync-enabled
license. For sync with Aspera Files, the Enterprise Server must be of version 3.7.1 or higher.

KNOWN ISSUES

Note:  This release was developed using two different issue-tracking systems. For this reason, the list below uses two
different formats for issue numbers.

ASDR-1740 - Drive with Shares 2.x: If you have configured a remote-to-local sync relationship with a share that
lacks Upload permissions, sync operations fail.

ASDR-1739 - If you have configured a sync relationship that includes some subfolders but excludes others, then later
change the sync to apply to the parent folder, Drive does not sync all subfolders of the parent folder. Workaround:
Select the desired folders manually, or reset the sync.
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ASDR-1723 - [Windows only] When you save a file from within an application with the File > Save As menu option,
then view the file in Explorer, its size appears to be of 0 bytes. However, the file is not in fact of 0 bytes, and can be
opened and used normally.

ASDR-1703 - [Windows only] With some Windows 7 themes, when you check out a file from within an application,
Drive's Activity window has display errors. Workaround: To avoid these display errors, choose a different theme as
follows:

1. At your Desktop, click anywhere and select Personalize.
2. In the Personalization window, click any of the Aero themes.

ASDR-1693 - When you configure a sync relationship for a node server, you can no longer select the topmost
checkbox. To select all directories under the topmost level, select them individually.

ASDR-1690 - [Mac OS X only] If the password for a Shares 2 account has expired, Drive hangs when you try to
remove the account.

ASDR-1676 - [Mac OS X only] Drive now uses extensions to Finder that provide some Drive functions right from the
familiar Finder interface. To use these features, you must have the Finder extensions enabled on your client system.
Do the following:

1. From the Apple menu, select System Preferences.
2. Go to Extensions > All.
3. Ensure that for Aspera Drive, the Share Menu and Finder extensions are enabled.

ASDR-1643 - Drive with Shares 2.x: When Shares is configured to use AES-256 encryption, Drive transfers fail.

ASDR-1592 - Drive with Shares 2.x: If you de-activate an account, then re-activate it, Drive does not correctly restore
the account. Workaround: Delete and then re-add the account to Drive.

ASDR-1574 - When you use Drive with Shares 2.x, you can configure sync relationships at the level of the share and
below. Sync cannot be set up for the account, organization, and project levels.

ASDR-1549 - [Mac OS X only] When you drag-and-drop a folder from one remote location to another in the same
window, Drive's Transfers window displays a generic icon for this transfer, rather than a folder icon.

ASDR-1537 - Drive with Files: If Drive has only one account, and if the Files token expires, Drive's Preferences
window does not present an option to refresh your authentication. Instead, you must close and re-open the
Preferences window.

ASDR-1536 - [Mac OS X only] When your Drive installation has only one account, its name appears in white text on
white background in Drive's Remote View. To address this, click in the right pane to browse the account.

ASDR-1527 - [Windows only] When you use Drive to open a file from within an application, if you opt not to check
out the file, Drive erroneously reports that the file does not exist.

ASDR-1526 - [Windows only] On 32-bit Windows systems, Drive may not work with applications that are low on
memory. This is because Drive uses FIPS security features, which require that a certain address space be free. If
possible, use a 64-bit system instead.

ASDR-1489 - In its Remote View (on Mac) and its entry in Explorer (on Windows), Drive does not always
automatically refresh to display the transferred content. The issue is particularly likely to occur when you have
transferred content from one transfer node to another. As a workaround, refresh the window manually to see the
transferred content.

ASDR-1476 - If you have configured a large number of folders for sync, your sync actions may time out. This is due
to Drive using a separate SSH session for each folder that is configured for sync.

ASDR-1380 and ASDR-1365 - [Mac OS X only] Because of the way icons and file thumbnails are retrieved, you may
experience degraded performance in Finder. To avoid this issue, disable the previews in Finder:

1. In Finder, go to View > Show View Options.
2. Clear (de-select) the Show icon preview check box.
3. Clear (de-select) the Show preview column check box.
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ASDR-1327 - [Mac OS X only] If a Files user's permissions are set such that renaming is not allowed in a shared
folder, when that user creates a new folder inside that shared folder, the new folder is named untitled folder
and cannot be renamed. For information on adjusting a user's permissions, see the Help Center within the Files
application.

ASDR-1317 - [Mac OS X only] If a shared folder lacks checkin/checkout permissions, Drive does not display a
Checked out by entry for that folder. Note that, while omitting this information from the Drive interface is logical
(the folder cannot be checked out), it differs slightly from the equivalent behavior in the Aspera Files UI.

ASDR-1276 - When you log in to Drive, if you enter the wrong password repeatedly, you can be locked out from
your authentication system (LDAP or Active Directory, for example). (CIM-530, CIM-720)

ASDR-1163 - [Mac OS X only] If you configure Drive's network preferences for a manual proxy configuration,
then switch to a system proxy configuration, when you switch back to manual, Drive does not correctly restore your
manual settings.

ASDR-1162 - [Mac OS X only] If you have configured Drive's network preferences for a system proxy configuration,
those proxy settings are not immediately applied to new Drive accounts. To apply system proxy settings to new Drive
accounts, you must restart the Drive application.

ASDR-1156 - For transfers between one transfer account and another, Drive permits this kind of transfer only within
the same account type. That is, you can transfer from one Files account to another; or from one Shares account to
another.

ASDR-1137 - Drive's checkin/checkout feature cannot be used in conjunction with sync functionality. If the synced
directory contains checked-out content, sync processes stall. Support for sync with checkin/checkout will be added in
a future release.

ASDR-1032 - [Mac OS X only] If you upgrade to the current release from Drive 2.0.2, and if Drive is configured with
both manually authenticated HTTP proxy and FASP proxy, you must re-enter the FASP proxy password when you re-
launch Drive.

ASDR-999 - When Drive is configured with an ISA proxy, you cannot add new Drive accounts for Enterprise Server
users with invalid certificates. This is due to the way the proxy validates certificates before the request reaches Drive.

ASDR-987 - Drive does not permit drag-and-drop transfers between shares in Finder. However, you can drag and
drop between remote shares in Drive's Remote View. For information on the Remote View, see the IBM Aspera Drive
Admin Guide (OS X).

ASDR-953 - Drive stops Sync when disk space runs low, and will not restart after more disk space has been made
available unless the sync selection is modified before restarting the sync.

ASDR-952 - [Mac OS X only] After a new installation of Drive with at least one account added, when you try to open
the Services tab, Drive takes you to the Account tab. To stop this behavior, click settings for packages or Sync.

ASDR-944 - [Mac OS X only] The Send with Aspera Drive context menu may not be available if you select more
than 1,000 items on your local machine. Workaround: To send 1,000 items or more, use the Send Files dialog.

ASDR-941 - When you drag and drop more than 125 files from your Faspex Inbox to your local machine, there is a
delay of at least 30 seconds before the transfers appear in the Activity window.

ASDR-931 - [Mac OS X only] When you browse content in Drive's remote view with a Files, Shares, or Enterprise
Server account, the display is limited to 1,000 files or folders.

ASDR-928 - [Mac OS X only] When you double-click a remote file to download and open it, if the file type does
not have an application associated with it, the file does not open once the file has been downloaded. Workaround:
Locate the downloaded file locally, double-click it, and select an application with which to open it.

ASDR-919 - [Mac OS X only] If the remote view remains open while you change the permissions on a shared folder,
Drive does not detect the change in permissions. You must exit the folder and refresh the remote view to update
permissions.

ASDR-840 - [Mac OS X only] When you add a Drive account for a server with an invalid certificate, Drive
incorrectly does not display a security alert.

http://download.asperasoft.com/download/docs/drive/3.1.0/admin_osx/webhelp/index.html
http://download.asperasoft.com/download/docs/drive/3.1.0/admin_osx/webhelp/index.html
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ASDR-830 - If a transfer server node is not configured for Sync, shared folders on that node nevertheless appear in
the list of folders to sync with.

Note:  In order set up Sync with a transfer server node, that node must be configured for Sync in its aspera.conf file
and must have the appropriate license. For further information, see the Admin Guide for your transfer server.

ASDR-768 - [Mac OS X only] You may encounter an intermittent "Authentication failed" error when Drive attempts
to automatically download a large number of packages simultaneously to the Inbox. For best performance, queuing
should be on and set to a low number (such as the default of 3). To turn on queuing in Drive, go to Preferences >
Transfers, select Enable queuing, and verify the value in the Maximum concurrent transfers field.

ASDR-624 - [Mac OS X only] Zlinux nodes cannot be added to Drive.

ASDR-607 - [Mac OS X only] Manual proxy with SAML accounts is not supported.

ASDR-599 - [Windows only] When Drive is configured to use HTTP proxy, if you make a transfer that includes a
large number of attachments, Drive's status bar does not display the correct status. The status bar indicates that the
transfer is complete, while in fact it is still in progress.

ADSR-576 - The Send Files window is slow to open if a Files account is selected.

ASDR-555 - Drive has a maximum screen resolution of 200%. If your screen is set to a higher DPI, some windows,
fields, and buttons do not display correctly.

ASDR-520 - [Windows only] After you upgrade from Drive 1.3.0, if you use the Cortana assistance tool to search,
Windows displays the older (1.3.0) Drive icon, rather than the newer (2.x) icon. This is due to an issue in Cortana.

ASDR-485 - [Windows 2012 R2 only] If you added accounts as an admin, the Drive context menu fails to appear
when you right-click a file or folder.

ASDR-435 - [Mac OS X only] If you delete a synced directory during a sync action, Drive may display intermittent
errors.

ASDR-414 - When you view a Faspex package in Drive's remote view (that is, within a file browser), if the package
contains folders, you cannot open the folders. This is the case for Inbox, Sent, and Archived packages.

ASDR-342 - When you change the permissions for a SAML user in Shares, those new permissions settings are not
reflected in Drive. To have the new permissions settings take effect, you must re-authenticate the user by re-adding
that account to Drive.

ASDR-340 - [Windows only] With the PingFederate SSO provider, when you are logging into Drive, enter your login
credentials and then press the Enter keyboard key (rather than using the Sign In button).

ASDR-269 - When you use Drive with Aspera Files, you can download the contents of folders shared by others, but
not the folders themselves.

ASDR-252 - [Windows only] When you use Drive with Aspera Files on Internet Explorer 8, the Files logo does not
display correctly.

ASDR-188 - If you are using Drive with Aspera Faspex 4.0.0 and your Faspex implementation is configured with
SAML accounts but does not have a default set, you must restart Drive in order to add any additional SAML accounts
from the same Faspex server.

ASDR-157 - [Windows only] Drive does not display all of your packages when you browse your Faspex account in
Windows Explorer if there are several thousand Inbox and Sent packages.

#34847 - If your transfer server's disk space is full, Drive may not offer the correct reason for the failed sync
operations.

#34826 - [Mac OS X only] If you add a SAML account that uses an invalid certificate, Drive erroneously does not
issue a warning.

#34722 - If a SAML account becomes invalid, Drive does not provide a way to re-enter the account credentials. To
work around this issue, you must remove the account and then add it again.

#33660 - Drive supports Aspera Shares 1.9.2 and higher. For SAML authentication, Drive requires Shares 1.9.3 or
higher.
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#33457 - When you attempt to create a Drive account for a SAML user whose account in Faspex or Shares has been
disabled, Drive does not issue an error or notification.

#33384 - [Windows only] On Windows 10, Drive's shortcuts do not appear in the Quick access list in Windows
Explorer.

#31919 - [Windows only] On Windows 8, if Drive accounts are created by the built-in Administrator user, the
Aspera Drive option does not appear when you right-click files or folders in Windows Explorer. Workaround: When
installing Drive, either install as a different user, or do a system-wide installation for all users.

#28181 - [Mac OS X only] Some configurations experience issues in syncing files with S3 storage.

#27587 - Temporary files that applications (such as Microsoft Office) create are excluded from sync transactions
because they can cause conflicts. The affected files are those with names of the form ~$* or ~*.tmp.

#27277 - [Mac OS X only] This issue affects users who attempt to upgrade Drive versions lower than 1.2.0 using the
"Check for updates" feature. When the user first attempts an automatic update, the update action fails with an error
message:

Failed to run update. Mount location not found:
/tmp/AsperaDrive

If the user attempts the automatic update a second time, the update succeeds.

#27153 - If the host is unreachable while Aspera Drive is sending a Faspex package, Drive may become unresponsive
for approximately one minute.

#26725 - [Mac OS X only] An initial sync of a large number of files results in high CPU usage.

#25913 - During a sync scheduled in Aspera Drive, even if files on the Shares server are changing (that is, are in the
process of being downloaded), Aspera Drive nevertheless attempts to sync those files, resulting in file errors and
conflicts.

#23230 - Aspera Drive cannot send packages to some valid Faspex usernames if those usernames contain the
following special characters:< > ; ( ) &

#22789 - When a directory is renamed, then renamed again to its original name, the correct name may not appear in
all Explorer windows.

#20513 - When you use Drive with Faspex to send a package to a dropbox, the dropbox name will not appear in the
autocomplete options. Instead, you must type the dropbox name manually.

PRODUCT SUPPORT

For on-line support resources for Aspera products, including raising new support tickets, please visit the Aspera
Support Portal. Note that you may have an existing account if you contacted the Aspera support team in the past.
Before creating a new account, first try setting a password for the email that you use to interact with us. You may also
call one of our regional support centers.

http://support.asperasoft.com/home
http://support.asperasoft.com/home
http://asperasoft.com/company/support

