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Introduction

IBM Aspera Drive is a data transfer client application that you run on your desktop or mobile device, to move files or
folders quickly and securely through your Aspera transfer server.

Drive provides the following services:

• Integrated desktop browsing of remote files.
• Drag-and-drop high-speed upload and download from cloud storage and traditional storage.
• Background synchronization of files.
• Sending and receiving of large files and data sets at global distances.

Installation

Installing Drive
To install Drive, follow the instructions in this section. To upgrade an existing Drive installation, see Upgrading Drive
on page 4.

Before installing Drive, obtain from your system administrator the URL and username/password credentials for at
least one transfer server for use with Drive.

1. Download the Drive installer:

AsperaDrive-version.msi
2. Install Drive by running AsperaDrive-version.exe. Follow the onscreen instructions.

Note:  During installation, the installer closes Windows Explorer.

You can select the checkbox in the setup wizard to start Drive automatically after installation, or you can start it

manually from the Windows Start menu. When Drive is running, the Drive icon  appears in the system tray.
3. To begin using Drive, use the wizard's onscreen instructions to add an account for use with an Aspera transfer

server.
For instructions on using the wizard, see the sections in this guide that describe adding and modifying accounts.
The Drive functions available to you depend on the type of server you connect to. See

• Adding a Drive Account for IBM Aspera on Cloud

or
• Adding a Drive Account for IBM Aspera Faspex

or
• Adding a Drive Account for IBM Aspera Shares

or
• Adding a Drive Account for Cloud Storage

Upgrading Drive
To determine whether Drive updates are available, do the following:

1. Check the release notes for information on new features and fixes since your last installation.
2. In the Windows system tray, right-click the Drive icon  and select Check for updates.
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3. If a newer release is available, download the Drive installer from the Check for updates link.
4. Install Drive by running AsperaDrive-version.exe. Follow the onscreen instructions.

Note:  The installer closes Windows Explorer, and if it finds a version of Drive already running on your system, it
shuts it down.

5. If a newer release is available, click Install Update and follow the onscreen instructions to upgrade your Drive
installation.

Note:  Before the upgrade can be applied, you must quit Drive.

Uninstalling Drive
To remove the Drive application from your system, do the following:

Note:  The uninstallation process closes Windows Explorer.

Either

• Select Start > All Programs > Aspera > Uninstall Aspera Drive.

or

• Select Start > Control Panel > Uninstall a program. Locate Drive in the list of installed programs; right-click it
and select Uninstall.

Working with IBM Aspera on Cloud

Drive with Aspera on Cloud
You can use Drive in conjunction with IBM Aspera on Cloud, a SaaS platform for file transfer and collaboration.
When Aspera on Cloud is integrated into Drive, you can do the following:

• See all your Aspera on Cloud workspaces, files, and packages (sent, received, and archived) in a single view in the
file browser.

• Share content with members of your organization.
• Send packages to a Aspera on Cloud inbox.
• See previews of image files.
• Check in and check out files for collaboration with a team.
• Transfer files and folders between your client computer and the server using the Windows Explorer file browser

interface, with the following standard Windows Explorer functions:

• browsing files and folders
• transferring files to and from your transfer account
• drag-and-drop 1

• creating new folders
• copy-and-paste

Note:  Drive does not currently support adding metadata to packages that it sends. Therefore, ensure that Aspera on
Cloud is not configured to have any required metadata fields when sending packages. You can configure optional
metadata fields, but Drive will ignore them.

For detailed information on using Aspera on Cloud, see the Help Center within the Aspera on Cloud application.

1 You may not download an entire shared folder by drag-and-drop. Instead, select contents of the folder to download.
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Adding a Drive Account for Aspera on Cloud
Use Drive's account setup wizard to configure a new transfer account. Have the following information available
before configuring an account:

• The URL of your Aspera on Cloud platform.
• The username and password that you have on Aspera on Cloud.

The steps below assume that you have Drive installed and running.

To add an Aspera on Cloud account to Drive, do the following:

1. Choose one of the following methods to open Drive's Accounts preferences:

• Right-click the Drive icon  in the system tray and select Preferences > Accounts.
• If you have the Drive Activity window open, select  > Preferences > Accounts.

2. Click  to add a transfer account.
The Account Wizard opens.

3. Fill in the fields with the following information about the Aspera on Cloud platform:

Field Description

Name A name for the account. This name is used only by
Drive.

Address The URL for the server that is running Aspera on
Cloud.

Click Next.
4. On the Authentication screen, with SAML Authentication selected, click Next.
5. Enter your Aspera on Cloud credentials:

Field Description

Username The username that you have on Aspera on Cloud.

Password The password that you have on Aspera on Cloud.

6. If your Aspera on Cloud platform is configured for synchronization, either

• Set up syncing. To do so, either accept the default directory shown for Place my files in, or click Change to
browse for a different folder (or create a new one).

or
• Click I'd rather not set up file syncing now.

By default, the sync folder is created inside the user's Documents folder. The name of the folder is the description
text you entered for the account.
For example, the default folder for an account named My Company Server would be the following:
C:\Users\username\Documents\My Company Server

If you choose to use the default folder, it is created automatically. If you want to change the sync folder, click
Change to browse for a different folder or create a new one.

7. If you opted to set up syncing on the previous screen, the Account Wizard prompts you to choose folders to sync.
You can either

• Select Synchronize with the selected remote folders and then select the folders on Aspera on Cloud to sync.
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Click the arrows to expand or collapse the folder view, and select the check boxes for the folders you want to
sync.

Choose the sync direction:

• Two-Way
• Remote to Local (default)
• Local to Remote

or
• Select I'll choose the folders to sync later.

8. Set up package downloading:

• Choose Automatically download my packages to and enter or browse to a location where you'd like to store
your downloaded packages.

or
• Choose I'd rather not set up automatic downloading now. You can change this setting later if you wish.

9. If you opted to set up package downloading in the previous step, now select a timeframe:

• Choose to download packages from a date in the past.

Select Download my packages from date sent and choose an option from the drop-down:

• Yesterday (default)
• A week ago
• A month ago
• The beginning of time

or
• Choose to download packages from now on.

10. Set up how you will check for new packages:

• Choose Check for new packages and select an automated time interval from the drop-down list.

or
• Choose to check for packages manually.

11. Click Finish to complete your Aspera on Cloud account setup.

Checkin/Checkout of Aspera on Cloud Content
You can use Drive to collaborate across your team, with clear "ownership" while a user is editing a document. With
the checkin/checkout feature, users check out a copy of a file, make local changes, and then check in the edited file.
While the first user has the file checked out, other users can view but not modify the master copy.

Note:  The checkin/checkout feature is available in Drive if it has been enabled in Aspera on Cloud at the
organization level.

Basic Checkin/Checkout Workflow

With Drive running, do the following:

1. In Windows Explorer, navigate to Aspera Drive > AsperaOnCloudAccountName >  workspaceName to the file
you want to work on.

2. Right-click the file and select Check out.

When you do this, Drive downloads a copy of the file to your local computer and places a lock on it, so that others
can't edit it until you check it back in.

The file opens in the default application for that file type.
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3. Edit the file and save your changes.
4. Back in Windows Explorer, check in the file. There are two ways to do this:

• In the Aspera on Cloud location where you checked out from, right-click the file and select Check in.
• In Aspera Drive > My Checkouts, right-click the file and select Check in.

Note:  If My Checkouts does not appear in Explorer, either

• You do not have any files checked out.

or
• You need to refresh the Explorer window.

When you check in the file, Drive uploads your edited copy to the Aspera on Cloud workspace and releases the
lock. Now others can see or check out the version with your changes.

Checking Out Files from Within an Application

In addition to checking out files from Windows Explorer, you can also check out files while you are working in an
application (such as Word, Photoshop, Notepad, or any other common application).

To check files out from within an application, do the following:

1. Select File > Open.
2. Browse to Aspera Drive > account_name and navigate to the file you want to work on.
3. Click Open.

When you open a file in this way, you are also checking it out through Drive.

Reverting a Checkout

Once you have checked out a file, you might need to release the lock you hold on it — for example, so that another
team member can edit it. Reverting a checkout removes the file lock and deletes your local copy.

Note:  If you revert a checkout on a file you have edited, you lose the changes you have made to the file. In the
Aspera on Cloud workspace, Drive restores the version of the file that you checked out.

To revert a checkout, do the following:

1. Go to My Checkouts.
2. Right-click the checked-out file and select Revert.

Drive alerts you that reverting will discard any changes you have made to the file.
3. Click Yes to finish.

Checkout Versus Open

Opening a file through Drive and checking it out look very similar in behavior: in both cases, Drive downloads a local
copy to your computer and opens it in the default application. But with checkout, Drive also places a lock on the file
so that other users cannot edit it.

If you double-click a file, this opens it but does not check it out. Take care to note the difference in your collaboration
workflow.

Viewing File Locks

You can use Drive to see who has a particular file checked out from the Aspera on Cloud repository.

Do the following:

1. In Windows Explorer, navigate through Aspera on Cloud to the location of the content you want information
about.

2. Select it.
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The entry in Windows Explorer shows you which user has checked out the file.

My Checkouts
In the course of your work, it may be easy to lose track of your checkouts, especially if

• You check out a large number of files.
• Your checked-out content comes from several different locations in Aspera on Cloud.
• Some time passes between checking out a file and checking it in.

The most convenient way to keep track of your checked-out content is to use the My Checkouts area of Windows
Explorer.

To see all of your current checkouts, click My Checkouts.

Moving, Renaming, and Deleting Checked-Out Content

You cannot move, rename, or delete a file or its parent folder while you (or any other user) has it checked out. Doing
so causes misalignments in the master repository in Aspera on Cloud.
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Instead, you can

1. Check the content back in (or revert your checkout).
2. Move, rename, or delete the content in Aspera on Cloud, once the file lock has been released. (That is, once the

content is not checked out by you or another user.)

Full Paths in My Checkouts

For convenience, the My Checkouts area uses a flat structure (a simple list) to show the content you have checked
out.

But you can also see the full path to the content's location in Aspera on Cloud through the Path column in Windows
Explorer. If the Path column is not shown, right-click in the Explorer window and select View > Details. If Explorer
is already in View > Details mode but does not show the Path column, refresh the Explorer window.

Troubleshooting the Checkin/Checkout Process

How do I find my checked-out content?

To see all of your current checkouts, click My Checkouts.

For more information, see My Checkouts on page 9.

How do I open a file someone else has checked out?

If another user has checked out a file, you can open it; but keep in mind that the copy you are viewing is local only,
and any changes you make to it cannot be committed to the Aspera on Cloud repository.

See Checkout Versus Open on page 8.

How do I see who has checked out a file I need?

In Windows Explorer, navigate through Aspera on Cloud to the content you want information about.

See Viewing File Locks on page 8.

I can't find the My Checkouts area.

In Windows Explorer, My Checkouts appears as an entry under Aspera Drive if all of the following are true:

• Your Drive installation is of version 3.0.2 or higher.
• You are using Drive with an Aspera on Cloud repository.
• You have checked out content from the Aspera on Cloud repository.

If all of the above are true, try refreshing the Explorer window:

In the lefthand pane of the Windows Explorer window, right-click Aspera Drive and select Refresh.

How do I know where my checkin will go in Aspera on Cloud?

When you check content back in, it returns to the Aspera on Cloud location where you checked it out from.

Also see Full Paths in My Checkouts on page 10.

I've reverted a checkout, but the file still appears in My Checkouts.

If you check out a file from one computer, then release the file lock (that is, revert the checkout) from a different
computer, the file still appears in the My Checkouts area on the computer where you checked it out.
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The file in My Checkouts is a local copy of the file, on the computer where you checked it out. Drive retains this
copy because you might have made changes to it that you need to retain. To remove it from the My Checkouts area,
right-click it and select Revert.

Working with IBM Aspera Faspex

Managing Drive Accounts for Faspex
An account in Drive allows you to use the browsing and transfer features between your client computer and the
Faspex transfer server. Managing accounts involves adding, modifying, and deleting accounts.

Before you can set up and manage accounts, you must obtain the credentials for your Faspex user account from your
system administrator. You will use these credentials to connect to the transfer server.

Adding a Drive Account for Faspex
Use Drive's account setup wizard to configure a new package transfer account. Have the following information
available before configuring an account:

• The address of the server where Faspex is installed and running.
• The username and password that you have on the Faspex server.

The steps below assume that you have Drive installed and running.

To add a Faspex account to Drive, do the following:

1. Choose one of the following methods to open Drive's Accounts preferences:

• Right-click the Drive icon  in the system tray and select Preferences > Accounts.
• If you have the Drive Activity window open, select  > Preferences > Accounts.

2. Click  to add a transfer account.
The Account Wizard opens.

3. Fill in the fields with the following information about the Faspex transfer server:

Field Description

Name A name for the account. The name is used only by
Drive.

Address The URL for the server that is running Faspex.

Click Next.
4. Enter your credentials on the transfer server:

Field Description

Username The username that you have on the Faspex server.

Password The password that you have on the Faspex server.

Drive then validates the connection.
5. If you are prompted to confirm the server's security certificate, indicate whether you trust the server.
6. Set up package downloading:
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• Choose Automatically download my packages to and enter or browse to a location where you'd like to store
your downloaded Faspex packages.

or
• Choose I'd rather not set up automatic downloading now. You can change this setting later if you wish.

7. If you opted to set up package downloading in the previous step, now select a timeframe:

• Choose to download packages from a date in the past.

Select Download my packages from date sent and choose an option from the drop-down:

• Yesterday (default)
• A week ago
• A month ago
• The beginning of time

or
• Choose to download packages from now on.

Click Next.
8. Set up how you will check for new packages:

• Choose Check for new packages and select an automated time interval from the drop-down list.

or
• Choose to check for packages manually.

9. Click Finish to complete creating the package transfer account.

Modifying a Drive Account for Faspex
You can modify the following aspects of a package transfer account:

• The local directory for received packages.
• Whether to overwrite packages.
• How often Drive should look for new packages.

The steps below assume that you have Drive installed and running, and that you have created at least one Drive
account that you want to modify.

1. Choose one of the following methods to open Drive's Accounts preferences:

• Right-click the Drive icon  in the system tray and select Preferences > Accounts.
• If you have the Drive Activity dialog open, select  > Preferences > Accounts.

2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Description The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the server.



 | Working with IBM Aspera Faspex | 13

4. In the Services area of the tab, click Packages: Settings.
The Packages dialog appears.

5. Modify the fields as needed:

Field Description

Download received packages to Specify the folder where downloaded packages will be saved.

You can download packages to the default folder: C:\Users
\windowsUsername\Aspera Drive\driveAccountName
Inbox, or you can click Change to provide a different folder name.

Overwrite packages that have
the same title

When a received package has the same title as an existing package, Drive
can either reuse the same folder (overwriting the existing package), or
create a new folder for the received package.

If you select this check box, packages with the same name as an already
existing downloaded package will be downloaded into the existing folder,
overwriting the older package.

If you do not select this check box, Drive will create a new folder for the
new package, so that the existing one is not overwritten. For example, if
you have already downloaded a package with a title of My_Files, and then
download another package with the same title, the files will be placed in
My_Files(2).

By default, this check box is not selected.

Do not download packages sent
by me

If this check box is selected, packages that you send to yourself or to work
groups that you belong to are not downloaded.

If this check box is not selected, packages that you send to yourself or
to work groups that you belong to are downloaded. (By default, it is not
selected.)

Packages are downloaded from

Note:  This field is not
configurable.

Displays the date since which Drive will search for packages to download.

For example, if this field displays 05/06/2014, Drive downloads any
packages that have arrived since May 6, 2014.

Check for new packages Select the interval in which to check for newly arrived packages.

6. Click OK to apply and save your settings, or click Cancel to cancel your selections.

Package Transfer: Overview
IBM Aspera Faspex is a file-exchange application. With a Web-based GUI, Faspex offers advanced management
options for fasp high-speed data transfer to match your organization's workflow.

When working with Faspex, you can perform the following tasks:

• Send packages.
• Receive packages.

Before you can send and receive packages using Drive, you must obtain the credentials for a user account from your
system administrator. You will use these credentials to connect to Faspex.

Sending Faspex Packages with Drive
1. Open the Send Files dialog by doing one of the following:
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• In Windows Explorer, right-click the files or folders you want to send and select Aspera Drive > Send files .
• If you have the Drive Activity window open, click  and select Send files.

2. In the Send Files  dialog, enter the following:

Field or Button Description

To The recipient of the package (required).

Title A short, relevant title for the package (required).

Notes A short message to the recipient of this package.

Files A list of the files and folders in the package that will be sent.

To add items to this list, click Add files or drag and drop from Windows Explorer into
this dialog.

Note:  If the content is a shortcut to a folder, the behavior is different with Add Files
versus drag-and-drop: If you use Add Files to add a shortcut to the package, the
package contains the folder itself (and its contents). If you use drag-and-drop to add
the shortcut to the package, the package contains a shortcut to the folder.

Encrypt sent files Select this check box if you want to encrypt files before sending them. When you
select Encrypt sent files and click Send Package, you are prompted to enter and
confirm a passphrase.

When you send encrypted packages, you must provide the recipients with the
encryption passphrases so that they can decrypt packages after they receive them.

Add files Click Add files to add a file or files to the package for transfer. You can also drag and
drop from Windows Explorer into this dialog.
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Field or Button Description

Add folder Click Add folder to add a folder to the package for transfer. You can also drag and
drop from Windows Explorer into this dialog.

Remove To remove an item from the package to be sent, select it in the Files list and click
Remove.

3. Click Send to send the package.

The Drive Activity window's Transfers tab opens to display the progress of the transfer.

Receiving Faspex Packages with Drive
• Getting More Information About a Transferred Package

a) Right-click the Drive icon  in the system tray, and select Activity.
b) Click Transfers to view a list of the recent packages that you have sent or downloaded.
c) With the buttons in the Transfers tab, you can perform the following additional tasks:

Opens the Transfer Monitor for more in-progress detail about the transfer.

In the Transfer Monitor, you can adjust the transfer rate (if settings allow).

Opens an Explorer window to the transfer destination folder (the "containing folder").

Stops an in-progress transfer.

Resumes a stopped or suspended transfer.

In addition to those actions, you can also right-click a package and select Remove to remove it from the list.
• Clearing a Transfer

If a transfer is not currently queued or running, you can remove it from the list:
On the Transfers tab, right-click a transfer in the list and select Remove.

• Looking for New Packages
If you have configured Drive to look for new packages at a certain interval, click the Inboxes tab to see when
Drive will next check for newly arrived packages.
You can also do the following:

• To stop checking for packages, click .
• To resume automatic checking for packages, click .
• To check for packages immediately, right-click an inbox and select Check now.

Note:  When you click the Check now button at the bottom right, Drive checks for new packages for all Faspex
accounts in Drive. When you right-click an individual Faspex account and select Check now, Drive only checks
for new packages for the selected account.

• Decrypting Received Packages
If you receive an encrypted package, see Decrypting Packages on page 20.

Working with IBM Aspera Shares
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Managing Drive Accounts for Shares
An account in Drive allows you to use the browsing and transfer features between your client computer and the
Shares transfer server. Managing accounts involves adding, modifying, and deleting accounts.

Before you can set up and manage accounts, you must obtain the credentials for your Shares user account from your
system administrator. You will use these credentials to connect to the transfer server.

Adding a Drive Account for Shares
To set up a transfer account, make sure you have the following information from the system administrator who
manages your Shares transfer server:

• A URL for the Shares transfer server, including a port and path (if applicable).
• A username and password that was set up on your Shares transfer server.

The steps below assume that you have Drive installed and running.

To add a Shares account to Drive, do the following:

1. Choose one of the following methods to open Drive's Accounts preferences:

• Right-click the Drive icon  in the system tray and select Preferences > Accounts.
• If you have the Drive Activity window open, select  > Preferences > Accounts .

2. Click  to add a transfer account.
The Account Wizard opens.

3. Fill in the fields with the following information about the Shares transfer server:

Field Description

Name A name for the account. The name is used only by
Drive.

Address The URL for the server that is running Shares.

4. If you are prompted to confirm the server's security certificate, indicate whether you trust the server.
5. Set your Shares server's authentication method:

• SAML Authentication

If you choose SAML Authentication, log in to the Shares server with this user's SAML credentials.

or
• Basic Authentication

If you choose Basic Authentication, enter the username and password for this user on the Shares server.
6. If the transfer server supports synchronization, either

• Set up syncing. To do so, either accept the default directory shown for Place my files in, or click Change to
browse for a different folder (or create a new one).

or
• Click I'd rather not set up file syncing now.

By default, the sync folder is created inside the user's Documents folder. The name of the folder is the description
text you entered for the account.
For example, the default folder for an account named My Company Server would be the following:
C:\Users\username\Documents\My Company Server
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If you choose to use the default folder, it is created automatically. If you want to change the sync folder, click
Change to browse for a different folder or create a new one.

7. If you opted to set up syncing on the previous screen, the Account Wizard prompts you to choose folders to sync.
You can either

• Select Synchronize with the selected remote folders and then select the folders on the server to sync.

Click the arrows to expand or collapse the folder view, and select the check boxes for the folders you want to
sync.

Choose the sync direction:

• Two-Way
• Remote to Local (default)
• Local to Remote

or
• Select I'll choose the folders to sync later.

8. When the screen displays a success message, click Finish to exit the Account Wizard.

Modifying a Drive Account for Shares
The steps below assume that you have Drive installed and running, and that you have created at least one Drive
account that you want to modify.

To modify a transfer account, do the following:

1. Choose one of the following methods to open Drive's Accounts preferences:

• Right-click the Drive icon  in the system tray and select Preferences > Accounts.
• If you have the Drive Activity window open, select  > Preferences > Accounts .

2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Description The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the server.

4. If your transfer server supports sync, you can modify sync settings under Services > Settings.
The Sync Settings dialog opens.

Field Description

Synchronize with the selected
remote folders

Add or remove server folders to sync.

Local Folder Path Select an alternate sync folder location on your computer.

Direction Select the direction of the sync.
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Click OK to put into effect any changes you have made.
5. Back in the Preferences dialog, click Save to put into effect any changes you have made.

Content Transfer: Overview
With a file-transfer account on Drive, you can transfer files and folders between your computer and the server, using
drag-and-drop and copy-and-paste in the Windows Explorer interface. Additional Windows Explorer capabilities with
a Drive transfer account include: creating, renaming, and deleting files and folders, and browsing the file system.

Before you can transfer files using Drive, you must obtain the credentials for a user account from your system
administrator. You will use these credentials to connect to the accounts server.

Note:  In order for Drive to run transfers, a Connect Server license is required on the node.

Transferring Content
Drive is accessible as a location in Windows Explorer. You can use standard Windows Explorer functions for moving
and copying files between the server and your local computer.

1. In Windows Explorer, navigate to Aspera Drive. The folders under that entry represent the accounts you have
created.

2. Use standard Windows Explorer functions for browsing through files and folders of each account, transferring
files to and from your transfer account, or creating new folders.

Note:  Depending on your account's permissions on the file transfer server, you might encounter limitations on the
following actions on the transfer server:

• browsing
• transfers
• file operations
• context menu options

3. Verify the status of your transfer:
If it is not already open, open the Drive Activity window. On the Transfers tab, in the list of transferred files and
folders, view the status of your transfer.
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You can see its status during a transfer, or after it has completed.
The buttons on the Activity window's Transfers tab have the following meanings:

Opens the Transfer Monitor for more in-progress detail about the transfer.

In the Transfer Monitor, you can adjust the transfer rate (if allowed).

Opens a Windows Explorer window to the transfer destination folder (the containing folder).

Stops an in-progess transfer.

Resumes a stopped or suspended transfer.

Note:  If a transfer is reported as complete but the file or folder does not appear in Windows Explorer, refresh the
Windows Explorer window.

Synchronization

Sync Capability: Overview
With Drive transfer accounts for Aspera on Cloud or Aspera Shares, you can set up Drive to sync folders
automatically on your client computer and the server whenever the folder's content changes in either location. Content
changes include

• modification of file contents
• changes in file and folder names
• creation and deletion of files and folders

Before you can sync files and folders using Drive, you must obtain the credentials for a user account from your
system administrator. You will use these credentials to connect to the transfer server.

Syncing Content

Monitoring Sync Status

You can monitor the status of a sync operation on the Activity Window > Sync tab.
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A progress bar shows in-progress synchronizations, and a countdown timer shows when the next synchronization will
take place.

Stopping and Starting Sync

You can stop and resume file syncing with these buttons on the Activity Window > Sync tab:

Stops an in-progress synchronization.

Resumes a stopped synchronization.

Resolving Sync Conflicts

A sync conflict occurs when the file on one side does not match the file on the other side. Files and folders may not be
synchronized for reasons such as insufficient permissions for the destination folder on the local computer.

If a file or folder cannot be synchronized, a conflict warning appears on the Activity Window > Sync tab.

To resolve the conflict, do the following:

1. Click the red conflict link.
2. In the dialog that appears, select the file or folder that is in a conflict state.
3. Click Resolve Selected Conflicts.

Drive renames the content on the local file system, appending the phrase conflict-mine. For example, the file
log.txt is renamed as log.conflict-mine.txt.

Working with Aspera Encrypted Files

Decrypting Packages
Encrypting a file protects it from unwanted access. When an encrypted file arrives after transfer, you must decrypt it
before you can use it.

Note:  Decrypting files requires a passphrase — a sequence of text that the sender of the package used to encrypt the
package. Before decrypting files, ensure that you have the necessary passphrase.

IBM Aspera Crypt works with Drive to decrypt downloaded files.



 | Drive Preferences | 21

To decrypt files you have downloaded, do the following:

1. Go to Activity > Transfers and select the encrypted package you want to decrypt.
2. Select  > Unlock encrypted files.

The encrypted files are automatically loaded into Crypt. The Aspera Crypt dialog appears.
3. Select a package or browse to the encrypted content.

When the encrypted content is loaded into Crypt, a status message appears at the bottom of the application,
displaying the number of items ready for decryption.

4. Type the passphrase into the field and click Decrypt.
You can also choose to decrypt the content later.

5. View the output in the Aspera Crypt viewing window.

The decrypted contents appear in the same directory as the original encrypted contents.

If the decrypted file (without the .aspera-env extension) already exists in the same folder, “(decrypted)” is added
to the filename.

If your Aspera Crypt viewing window has multiple decrypted items listed, you can use the View drop-down list
to sort the items by latest, finished, or failed.

Configuring Your Decryption Settings
You can adjust the settings that are used when packages are decrypted. In the Crypt window, do the following:

1. Click Settings.
2. Configure the following:

• Delete encrypted files when finished

When this check box is selected, Crypt removes the encrypted files from your system after the destination
(decrypted) content has been created.

• Number of concurrent threads for decryption

Select the number of threads that are decrypting at any given time. A higher setting means that files will be
decrypted more quickly, but this may slow down the rest of your computer while it is running. The options are
1 (default), 2, 4 and 8.

Drive Preferences

Setting Your Preferences in Drive
Through the Preferences dialog, you can set your preferences for the following areas:

• general settings
• accounts
• transfers
• network
• bandwidth

To set your preferences, open the Preferences dialog by doing one of the following:

• With Drive running, right-click the Drive icon  in the system tray and click Preferences.
• If you have the Drive Activity window open, select  > Preferences.
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General Preferences
You can set the following preferences at Preferences > General:

Field Description

Automatically launch
Aspera Drive when
Windows starts

Select this check box to automatically launch Drive when you log into your
Windows account.

Remove transfer list items Select whether to remove the entry automatically from the transfer view after it has
completed, or to manually remove items.

Manually is selected by default.

Logging Level Choose the level of information to be recorded in the Drive logs. Options are:

• Info
• Debug
• Trace

Note:  Do not change this setting unless Aspera Technical Support asks you to do
so.

Click Apply or OK to apply and save your settings, or click Cancel to cancel your selections.

Account Preferences
Select Preferences > Accounts to create, configure, modify, and remove accounts.

Adding an Account

• For instructions on adding Drive accounts for use with a Shares transfer server, see Adding a Drive Account for
Shares on page 16.

• For instructions on adding Drive accounts for use with a Faspex transfer server, see Adding a Drive Account for
Faspex on page 11.

• For instructions on adding Drive accounts for use with cloud storage, see Adding a Drive Account for Cloud
Storage.

Modifying an Account

• For Shares, see Modifying a Drive Account for Shares on page 17.
• For Faspex, see Modifying a Drive Account for Faspex on page 12.
• For cloud accounts, see Modifying a Drive Account for Cloud Storage.

Removing an Account

To remove an account and manage the account's files after removal, do the following:

1. In the list of accounts, select an account to be removed.
2.

Click  to remove the account.

When you remove an account, all account transfers and services associated with that account are stopped and
removed.

3. Click Yes to confirm the account removal, or click No to cancel the account removal.

Configuring Sync Settings
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For Drive accounts that are set up with Aspera on Cloud or Shares as the transfer server, you can configure
synchronization settings, such as which remote folders to sync with, and the direction of the synchronization
relationship.

For instructions on using synchronization features, see Syncing Content on page 19.

Configuring Faspex Account Settings

For Drive accounts that are set up with Faspex as the transfer server, you can configure the following:

• The local directory for received packages.
• Whether to overwrite packages.
• How often Drive should look for new packages.

For instructions, see Modifying a Drive Account for Faspex on page 12.

Transfer Preferences
Select Preferences > Transfers to set your transfer preferences.

1. Configure settings on the Transfers tab:

Field Description

Enable queuing When this check box is selected, Drive limits the number of concurrent
transfers to the number specified in the Maximum concurrent transfers
field.

Any transfers above this value are queued and then started once the number of
concurrent transfers drops below the specified value.

Note:  When transfers are queued, you can start them manually from the
Activity > Transfers window.

Maximum concurrent
transfers

If queuing is enabled, you can enter a maximum number of concurrent
transfers in this field.

By default, a maximum of three concurrent transfers are allowed.

When queuing is not enabled, this field is not available.

Automatically retry failed
transfers

• Attempts
• Interval

When this check box is selected, Drive retries failed transfers.

It will make the specified number of retry Attempts in a specified time
Interval.

If you want Drive to retry failed transfers, specify the number of attempts and
the interval in which Drive will try to resend in seconds, minutes, or hours.

By default, this feature is enabled, with three retry attempts and at 30-second
intervals.

Sync: Interval Specify the interval between synchronizations for each account that has the
sync feature enabled.

By default, synchronizations are set for 30-second intervals.

2. Click Apply or OK to apply and save your settings, or click Cancel to cancel your selections.

Network Preferences
Select Preferences > Network to set your network preferences.
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1. In the HTTP Proxy area, set the following preferences:

Field Description

Obtain proxy configuration
from

Select whether to obtain the proxy configuration from the system, or to
provide a manual proxy configuration.

By default, System is selected.

Note:  If you select System and your system settings have changed since you
last used system proxy configurations with Drive, you must restart Drive.

If you select Manual, the Use HTTP Proxy fields become available. See
below for a description of these fields.

Use HTTP Proxy

• Username
• Password
• Address and Port

If you selected Manual from the previous drop-down list, use these fields to
define your proxy configuration. Type the following information:

• your username
• your password
• your server's URL or IP address, and port number

Note:  For some proxies, username and password are optional.

2. If you will use a FASP proxy for your transfers, set the following preferences in the dialog's FASP Proxy area:

Field Description

Use FASP Proxy (DNAT) If your transfers will use an IBM Aspera FASP Proxy server, select this check
box.

Secure (DNATS) Select this check box if your FASP Proxy uses a secure connection.

• Username
• Password
• Address and Port

Use these fields to define your FASP Proxy configuration. Type the following
information:

• your server username
• your server password
• your server's URL or IP address, and port number

Note:  These fields are enabled only if Use FASP Proxy (DNAT) is selected.

3. Click Apply or OK to apply and save your settings, or click Cancel to cancel your selections.

Bandwidth Preferences
Transfer speeds depend on server settings and your network connectivity. To limit transfer rates, do the following:

1. Select Preferences > Bandwidth and set your bandwidth preferences:

Field Description

Download: Limit to When the Limit to check box is selected, you can set the download rate in either
megabits per second (Mbps) or kilobits per second (Kbps).

This rate applies to each download.

Upload: Limit to When the Limit to check box is selected, you can set the upload rate in either
megabits per second (Mbps) or kilobits per second (Kbps).
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Field Description
This rate applies to each upload.

2. Click Apply or OK to apply and save your settings, or click Cancel to cancel your selections.

Technical Support

Support Websites

For an overview of IBM Aspera Support services, go to https://asperasoft.com/company/support/.

To view product announcements, webinars, and knowledgebase articles, as well as access the Aspera Support
Community Forum, sign into the IBM Aspera Support site at https://www.ibm.com/mysupport/ using your IBMid
(not your company Aspera credentials), or set up a new account. Search for Aspera and select the product. Click
Follow to receive notifications when new knowledgebase articles are available.

Personalized Support

You may contact an Aspera support technician 24 hours a day, 7 days a week, through the following methods, with a
guaranteed 4-hour response time.

Email aspera-support@ibm.com

Phone (North America) +1 (510) 849-2386, option 2

Phone (Europe) +44 (0) 207-993-6653 option 2

Phone (Singapore) +81 (0) 3-4578-9357 option 2
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