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Introduction

IBM Aspera Drive is a data transfer client application that you run on your desktop or mobile device, to move files or
folders quickly and securely through your Aspera transfer server.

When Drive is connected to the IBM Aspera on Cloud SaaS platform, you can perform the following tasks:

• Browse the contents of an Aspera on Cloud workspace from the file browser.
• Transfer files and packages from within the same browser view.
• Synchronize local folders with folders on the transfer server, in both directions.

When Drive is connected to an IBM Aspera Faspex transfer server, you can perform the following tasks:

• Send packages to Faspex users and workgroups.
• Automatically download packages as they are received.
• See into Faspex packages from within the file browser.

When Drive is connected to an IBM Aspera Shares transfer server, you can perform the following tasks:

• Browse and manage the file systems on the transfer server.
• Transfer files and folders to and from the transfer server.
• Synchronize local folders with folders on the transfer server, in both directions.

You can also connect Drive directly to a server where only IBM Aspera High-Speed Transfer Server is running. For
more information on this configuration, contact Aspera Technical Support.

Installation

Installing Drive
To install Drive, follow the instructions in this section. To upgrade an existing Drive installation, see Upgrading Drive
on page 5.

Before installing Drive, obtain from your system administrator the URL and username/password credentials for at
least one transfer server for use with Drive.

1. Download and open the Drive disk image:

AsperaDrive-version.dmg
2. After you have agreed to the license agreement, the Drive application appears in a Finder window. Drag-and-drop

the Drive application to the desired location (such as the desktop or the Applications folder).
3. If Drive still appears as a device in your Finder window, eject it.
4. Enable the extensions that provide some Drive functions from the Finder interface.

a) From the Apple menu, select System Preferences.
b) Go to Extensions > All.
c) Ensure that for Aspera Drive, the Share Menu and Finder extensions are enabled.

5. If you are using Drive with Aspera on Cloud, you may need to log in as an admin.
If so, consult your system administrator for these credentials.

6. To begin using Drive, go to where you placed the application and double-click it.
A wizard opens, for adding an account for use with an Aspera transfer server.

For instructions on using the wizard, see the sections in this guide that describe adding and modifying accounts.
The Drive functions available to you depend on the type of server you connect to. See

https://support.asperasoft.com/home
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• Adding a Drive Account for IBM Aspera on Cloud

or
• Adding a Drive Account for IBM Aspera Faspex

or
• Adding a Drive Account for IBM Aspera Shares

or
• Adding a Drive Account for Cloud Storage

Upgrading Drive
To determine whether Drive updates are available, do the following:

1. Check the release notes for information on new features and fixes since your last installation.
2. While Drive is running, click the Drive icon  in the menu bar, and select Check for Updates.
3. If a newer release is available, click Install Update and follow the onscreen instructions to upgrade your Drive

installation.

Note:  Before the upgrade can be applied, you must quit Drive.

Uninstalling Drive
To remove the Drive application from your system, run the uninstallation script:

1. Open a terminal window:

Applications > Utilities > Terminal
2. At the terminal prompt, type the following command:

$ /installationDirectory/Aspera\ Drive.app/Contents/Resources/
uninstall_drive.sh

installationDirectory is the directory where you placed the Drive application when you installed it. For example, /
Users/yourUserName/Desktop or /Applications.

3. Answer the prompts and finish the uninstallation process.

Working with IBM Aspera on Cloud

Drive with Aspera on Cloud
You can use Drive in conjunction with IBM Aspera on Cloud, a SaaS platform for file transfer and collaboration.
When Aspera on Cloud is integrated into Drive, you can do the following:

• See all your Aspera on Cloud workspaces, files, and packages (sent, received, and archived) in a single view in the
file browser.

• Share content with members of your organization.
• Send packages to a Aspera on Cloud inbox.
• Check in and check out files for collaboration with a team.
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Note:  Drive does not currently support adding metadata to packages that it sends. Therefore, ensure that Aspera on
Cloud is not configured to have any required metadata fields when sending packages. You can configure optional
metadata fields, but Drive will ignore them.

Seeing into Your Aspera on Cloud Workspace

To view the contents of a location in Aspera on Cloud, you can use any of these interfaces:

• Aspera on Cloud itself (in a web browser)
• Drive's Remote View

See Understanding the Remote View on page 7.

For detailed information on using Aspera on Cloud, see the Help Center within the Aspera on Cloud application.

Adding a Drive Account for Aspera on Cloud
Use Drive's account setup wizard to configure a new transfer account. Have the following information available
before configuring an account:

• The URL of your Aspera on Cloud platform.
• The username and password that you have on Aspera on Cloud.

The steps below assume that you have Drive installed and running.

To add an Aspera on Cloud account to Drive, do the following:

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. Click  to add a transfer account.

The Account Wizard opens.
3. Fill in the fields with the following information about the Aspera on Cloud platform:

Field Description

Name A name for the account. This name is used only by
Drive.

Address The URL for the server that is running Aspera on
Cloud.

Click Next.
4. On the Authentication screen, with SAML Authentication selected, click Next.
5. Enter your Aspera on Cloud credentials:

Field Description

Username The username that you have on Aspera on Cloud.

Password The password that you have on Aspera on Cloud.

6. If your Aspera on Cloud platform is configured for synchronization, either

• Set up syncing. To do so, either accept the default directory shown for Place my files in, or click Change to
browse for a different folder (or create a new one).

or
• Click I'd rather not set up file syncing now.

7. If you opted to set up syncing on the previous screen, the Account Wizard prompts you to choose folders to sync.
You can either
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• Select Synchronize with the selected remote folders and then select the folders on Aspera on Cloud to sync.

Click the arrows to expand or collapse the folder view, and select the check boxes for the folders you want to
sync.

Choose the sync direction:

• Two-Way
• Remote to Local (default)
• Local to Remote

or
• Select I'll choose the folders to sync later.

8. Set up package downloading:

• Choose Automatically download my packages to and enter or browse to a location where you'd like to store
your downloaded packages.

or
• Choose I'd rather not set up automatic downloading now. You can change this setting later if you wish.

9. If you opted to set up package downloading in the previous step, now select a timeframe:

• Choose to download packages from a date in the past.

Select Download my packages from date sent and choose an option from the drop-down:

• Yesterday (default)
• A week ago
• A month ago
• The beginning of time

or
• Choose to download packages from now on.

10. Set up how you will check for new packages:

• Choose Check for new packages and select an automated time interval from the drop-down list.

or
• Choose to check for packages manually.

11. Click Finish to complete your Aspera on Cloud account setup.

Checkin/Checkout of Aspera on Cloud Content
You can use Drive to collaborate across your team, with clear "ownership" while a user is editing a document. With
the checkin/checkout feature, users check out a copy of a file, make local changes, and then check in the edited file.
While the first user has the file checked out, other users can view but not modify the master copy.

Note:  The checkin/checkout feature is available in Drive if it has been enabled in Aspera on Cloud at the
organization level.

Understanding the Remote View

Drive's checkin/checkout feature takes place in a window called Remote View:
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Drive's Remote View lets you see the contents of a Aspera on Cloud workspace, outside of the Aspera on Cloud
interface.

Remote View Versus Finder

In appearance, Drive's Remote View closely resembles Finder, the Mac OS X file browser. The most crucial
difference is that Drive checkin/checkout functions are performed in Remote View. In Finder, you can see the current
contents of a Aspera on Cloud location, but not the checkin/checkout status of those contents.

Basic Checkin/Checkout Workflow

With Drive running, do the following:

1. Open Remote View:

a. In the menu bar at the top of your screen, click the Drive icon.
b. Select Aspera Drive > AsperaOnCloudAccountName.

2. In Remote View, navigate through your workspace to the file you want to work on, and select it.
3. Click Check out.

When you do this, Drive downloads a copy of the file to your local computer and places a lock on it, so that others
can't edit it until you check it back in.

The file opens in the default application for that file type.
4. Edit the file and save your changes.
5. Back in Remote View, click My Checkouts in the lefthand pane, and check it in. There are several ways to do

this:

• Select the file and click Check in.
•

Select the file and click  > Check in.
• Right-click the file and select Check in.

When you do this, Drive uploads your edited copy to the Aspera on Cloud workspace and releases the lock. Now
others can see or check out the version with your changes.

Checking In a New File

To check in content that is not yet stored in Aspera on Cloud, the process is almost the same as for existing content in
Aspera on Cloud.

With Drive running, do the following:
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1. Create the file and save it.
2. In the Save dialog, give your new file a filename and browse to the desired location in Aspera on Cloud.
3. In Remote View, click My Checkouts in the lefthand pane, and check it in. There are several ways to do this:

• Select the file and click Check in.
•

Select the file and click  > Check in.
• Right-click the file and select Check in.

Reverting a Checkout

Once you have checked out a file, you might need to release the lock you hold on it — for example, so that another
team member can edit it. Reverting a checkout removes the file lock and deletes your local copy.

Note:  If you revert a checkout on a file you have edited, you lose the changes you have made to the file. In the
Aspera on Cloud workspace, Drive restores the version of the file that you checked out.

To revert a checkout, do the following:

1. Go to My Checkouts.
2. Right-click the checked-out file and select Revert.

Drive alerts you that reverting will discard any changes you have made to the file.
3. Click Revert to finish.

Checkout Versus Open

Opening a file through Drive and checking it out look very similar in behavior: in both cases, Drive downloads a local
copy to your computer and opens it in the default application. But with checkout, Drive also places a lock on the file
so that other users cannot edit it.

If you double-click a file, this opens it but does not check it out. Take care to note the difference in your collaboration
workflow.

Viewing File Locks

You can use Drive to see who has a particular file checked out from the Aspera on Cloud repository.

Do the following:

1. In Remote View, navigate through Aspera on Cloud to the location of the content you want information about.
2. Select it.

The entry in Remote View shows you which user has checked out the file.
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My Checkouts
In the course of your work, it may be easy to lose track of your checkouts, especially if

• You check out a large number of files.
• Your checked-out content comes from several different locations in Aspera on Cloud.
• Some time passes between checking out a file and checking it in.

The most convenient way to keep track of your checked-out content is to use the My Checkouts area of Drive's
Remote View.

To see all of your current checkouts, click My Checkouts.
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Moving, Renaming, and Deleting Checked-Out Content

You cannot move, rename, or delete a file or its parent folder while you (or any other user) has it checked out. Doing
so causes misalignments in the master repository in Aspera on Cloud.

Instead, you can

1. Check the content back in (or revert your checkout).
2. Move, rename, or delete the content in Aspera on Cloud, once the file lock has been released. (That is, once the

content is not checked out by you or another user.)

Full Paths in My Checkouts

For convenience, the My Checkouts area uses a flat structure (a simple list) to show the content you have checked
out.

But you can also see the full path to the content's location in Aspera on Cloud through the Local path and Remote
path metadata in Remote View.

Troubleshooting the Checkin/Checkout Process

How do I find my checked-out content?

To see all of your current checkouts, click My Checkouts.

For more information, see My Checkouts on page 10.

How do I open a file someone else has checked out?

If another user has checked out a file, you can open it; but keep in mind that the copy you are viewing is local only,
and any changes you make to it cannot be committed to the Aspera on Cloud repository.

See Checkout Versus Open on page 9.
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How do I see who has checked out a file I need?

In Remote View, navigate through Aspera on Cloud to the content you want information about.

See Viewing File Locks on page 9.

I can't find the My Checkouts area.

Verify that you are using Remote View rather than Finder.

Finder and Remote View are visually quite similar, but you cannot use Drive checkin/checkout functions within
Finder. If your window lacks a My Checkouts entry in its leftmost pane, it is most likely a Finder window.

To open Remote View,

1. Go to the menu bar at the top of your screen and click the Drive icon.
2. Select Aspera Drive >AsperaOnCloudAccountName.

The window that appears is Drive's Remote View.

For further information, see Understanding the Remote View on page 7.

How do I know where my checkin will go in Aspera on Cloud?

When you check content back in, it returns to the Aspera on Cloud location where you checked it out from.

Also see Full Paths in My Checkouts on page 11.

I've reverted a checkout, but the file still appears in My Checkouts.

If you check out a file from one computer, then release the file lock (that is, revert the checkout) from a different
computer, the file still appears in the My Checkouts area on the computer where you checked it out.

The file in My Checkouts is a local copy of the file, on the computer where you checked it out. Drive retains this
copy because you might have made changes to it that you need to retain. To remove it from the My Checkouts area,
right-click it and select Revert.

Can I check out a file while I'm working in an application?

If you're working in an application (for example, TextEdit, Photoshop, or any other common application), you can use
the application's own File menu to open files that are shared with you through Drive. But when you open a file in this
way, it is a read-only local copy.

To check out the file, use Drive's Remote View. See Understanding the Remote View on page 7

Working with IBM Aspera Faspex

Drive with Faspex
IBM Aspera Faspex is a file-exchange application built on IBM Aspera High-Speed Transfer Server as a centralized
transfer solution. With a Web-based GUI, Faspex offers advanced management options for FASP high-speed transfer
to match your organization's workflow.

When working with Faspex, you can perform the following tasks:

• Send packages.
• Receive packages.

Before configuring Faspex to work with Drive, you need the following:
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• A computer running the correct version of Faspex. For instructions on how to install Faspex, see the IBM Aspera
Faspex documentation.

• Credentials for Faspex user accounts. Users will use these accounts in Drive to connect to Faspex.

Configuring Faspex
To install and configure Faspex, follow the instructions in the IBM Aspera Faspex Admin Guide.

Note:  Drive does not currently support adding metadata to packages that it sends. Therefore, ensure that Faspex is
not configured to have any required metadata fields when sending packages. You can configure optional metadata
fields, but Drive will ignore them.

Adding a Drive Account for Faspex
Use Drive's account setup wizard to configure a new package transfer account. Have the following information
available before configuring an account:

• The address of the server where Faspex is installed and running.
• The username and password that you have on the Faspex server.

The steps below assume that you have Drive installed and running.

To add a Faspex account to Drive, do the following:

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. Click  to add a transfer account.

The Account Wizard opens.
3. Fill in the fields with the following information about the Faspex transfer server:

Field Description

Name A name for the account. The name is used only by
Drive.

Address The URL for the server that is running Faspex.

Click Next.
4. Enter your credentials on the transfer server:

Field Description

Username The username that you have on the Faspex server.

Password The password that you have on the Faspex server.

Drive then validates the connection.
5. If you are prompted to confirm the server's security certificate, indicate whether you trust the server.
6. Set up package downloading:

• Choose Automatically download my packages to and enter or browse to a location where you'd like to store
your downloaded Faspex packages.

or
• Choose I'd rather not set up automatic downloading now. You can change this setting later if you wish.

7. If you opted to set up package downloading in the previous step, now select a timeframe:

• Choose to download packages from a date in the past.

https://downloads.asperasoft.com/en/downloads/6
https://downloads.asperasoft.com/en/downloads/6
https://downloads.asperasoft.com/en/downloads/6
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Select Download my packages from date sent and choose an option from the drop-down:

• Yesterday (default)
• A week ago
• A month ago
• The beginning of time

or
• Choose to download packages from now on.

Click Next.
8. Set up how you will check for new packages:

• Choose Check for new packages and select an automated time interval from the drop-down list.

or
• Choose to check for packages manually.

9. Click Finish to complete creating the package transfer account.

Modifying a Drive Account for Faspex
You can modify the following aspects of a package transfer account:

• The local directory for received packages.
• Whether to overwrite packages.
• How often Drive should look for new packages.

The steps below assume that you have Drive installed and running, and that you have created at least one Drive
account that you want to modify.

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Description The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the server.

4. On the Services pane, click Packages: Settings.
The Packages dialog appears.

5. Modify the fields as needed:

Field Description

Download received packages to Specify the folder where downloaded packages will be saved.

You can download packages to the default folder: /
Users/macUsername/Documents/driveAccountName, or you
can click Change to provide a different folder name.
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Field Description

Overwrite packages that have
the same title

When a received package has the same title as an existing package, Drive
can either reuse the same folder (overwriting the existing package), or
create a new folder for the received package.

If you do not select this check box, Drive will create a new folder for the
new package, so that the existing one is not overwritten. (By default, this
check box is not selected.)

For example, if you have already downloaded a package with a title of
My_Files, and then download another package with the same title, the files
will be placed in My_Files(2).

If you select this check box, Drive will place the new package into the
existing My_Files folder instead of creating a new My_Files(2) folder. If
My_Files already contains a file with the same filename, the existing file
will be overwritten.

Do not download packages sent
by me

If this field is selected, packages that you send to yourself or to work
groups that you belong to are not downloaded. (By default, it is selected.)

If this field is not selected, packages that you send to yourself or to work
groups that you belong to are downloaded.

Packages are downloaded from

Note:  This field is not
configurable.

Displays the date since which Drive will search for packages to download.

For example, if this field displays 05/06/2014, Drive downloads any
packages that have arrived since May 6, 2014.

Check for new packages Select the interval in which to check for newly arrived packages.

6. Click OK to apply and save your settings, or click Cancel to cancel your selections.

Sending Faspex Packages with Drive
1. Open the Send Files dialog by doing one of the following:

• In the menu bar, click the Drive icon  and select Send To.
• In the Finder, right-click an item and select Send with Aspera Drive (or Services > Send with Aspera Drive,

depending on your Mac configuration).
2. In the Send Files  dialog, enter the following:

Field or Button Description

Account The account you will use to send the package from (required).

To The recipient of the package (required).

Title A short, relevant title for the package (required).

Notes A short message to the recipient of this package.

Files A list of the files and folders in the package that will be sent.

To add items to this list, click Add files or drag and drop from the Finder into the Send
Files dialog.

Encrypt sent files Select this check box if you want to encrypt files before sending them. When you
select Encrypt sent files and click Send Package, you are prompted to enter and
confirm a passphrase.
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Field or Button Description
When you send encrypted packages, you must provide the recipients with the
encryption passphrases so that they can decrypt packages after they receive them.

Add files Click Add files to add a file or files to the package for transfer. You can also drag and
drop files from Finder into this dialog.

Add folder Click Add folder to add a folder to the package for transfer. You can also drag and
drop folders from Finder into this dialog.

Remove To remove an item from the package to be sent, select it in the Files list and click
Remove.

3. Click Send to send the package.

The Drive Activity window's Transfers pane opens to display the progress of the transfer.

Receiving Faspex Packages with Drive
• Getting More Information About a Transferred Package

a) In the menu bar, click the Drive icon  and select Activity.
b) Click Transfers to view a list of the recent packages that you have sent or downloaded.
c) With the buttons in the Transfers pane, you can perform the following additional tasks:

Opens the Transfer Monitor for more in-progress detail about the transfer.

In the Transfer Monitor, you can adjust the transfer rate (if settings allow).

Opens a Finder window to the transfer destination folder (the "containing folder").

Stops an in-progress transfer.

Resumes a stopped or suspended transfer.

In addition to those actions, you can also right-click a package and select Remove to remove it from the list.

• Clearing a Transfer
If a transfer is not currently queued or running, you can remove it from the list:
On the Transfers pane, right-click a transfer in the list and select Remove.

• Looking for New Packages
If you have configured Drive to look for new packages at a certain interval, click the Inbox pane to see when
Drive will next check for newly arrived packages.
You can also do the following:

• To stop checking for packages, click .
• To resume automatic checking for packages, click .
• To check for packages immediately, right-click an inbox and select Check Now.

• Decrypting Received Packages
If you receive an encrypted package, see Decrypting Packages on page 25.
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Working with IBM Aspera Shares

Drive with Shares
IBM Aspera Shares is a multinode web transfer application that enables organizations to share content with internal
and external users.

Drive accounts that are set up with Shares as the transfer server provide the following functions:

• Users can transfer files and folders between their client computer and the server using the Finder file browser
interface, with the following standard Finder functions:

• drag-and-drop
• browsing files and folders
• transferring files to and from your transfer account
• creating new folders

• You can set up Drive to sync folders automatically on the client computer and on the server whenever contents
change. Content changes include

• modification of file contents
• changes in file and folder names
• creation and deletion of files and folders

The sync feature can be configured to be one-way or bidirectional.

For detailed information on Shares, including system requirements and installation instructions, see see the IBM
Aspera Shares documentation

Configuring Shares
Before configuring Shares to work with Drive, you need the following:

• A computer running the correct version of Shares and Enterprise Server.
• On each node on the Shares server, a supported version of Connect Server with a Drive-enabled license.
• Credentials for your users' Shares accounts. Users will enter these account credentials in Drive, to connect to

Shares.

Note:  If you will use the synchronization feature, you must ensure that the Enterprise Server is configured to use
token authentication.

1. Log in to your Shares instance as administrator, and go to Admin > Accounts > Users.
2. For each Shares user account that will use Drive, click Edit.
3. On the Security tab, ensure that the API Login check box is selected.

On Shares 1.6 and later versions, this permission is enabled by default whenever new users are created.
4. Create shares, and authorize users for each share.

For detailed instructions on creating shares and authorizing users, see the  IBM Aspera Shares Administrator
Guide.

5. For each authorized user of a share, enable the following permissions to allow users to view, edit, or delete files
and folders when using Drive:

In Order to Allow This Action on Drive... ...Enable This Check Box on Shares

View browse

https://downloads.asperasoft.com/en/downloads/34
https://downloads.asperasoft.com/en/downloads/34
https://downloads.asperasoft.com/en/downloads/34
https://downloads.asperasoft.com/en/downloads/34
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In Order to Allow This Action on Drive... ...Enable This Check Box on Shares
download

Edit upload

mkdir

rename

Delete delete

6. For each Shares user account that will use Drive, repeat these steps.

For more information on Shares, see the Shares Administrator Guide.

Adding a Drive Account for Shares
To set up a transfer account, make sure you have the following information from the system administrator who
manages your Shares transfer server:

• A URL for the Shares transfer server, including a port and path (if applicable).
• A username and password that was set up on your Shares transfer server.

The steps below assume that you have Drive installed and running.

To add a Shares account to Drive, do the following:

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. Click  to add a transfer account.

The Account Wizard opens.
3. Fill in the fields with the following information about the Shares transfer server:

Field Description

Name A name for the account. The name is used only by
Drive.

Address The URL for the server that is running Shares.

4. If you are prompted to confirm the server's security certificate, indicate whether you trust the server.
5. Set your Shares server's authentication method:

• SAML Authentication

If you choose SAML Authentication, log in to the Shares server with this user's SAML credentials.

or
• Basic Authentication

If you choose Basic Authentication, enter the username and password for this user on the Shares server.
6. If the transfer server supports synchronization, either

• Set up syncing. To do so, either accept the default directory shown for Place my files in, or click Change to
browse for a different folder (or create a new one).

or
• Click I'd rather not set up file syncing now.

7. If you opted to set up syncing on the previous screen, the Account Wizard prompts you to choose folders to sync.
You can either

• Select Synchronize with the selected remote folders and then select the folders on the server to sync.

https://downloads.asperasoft.com/en/downloads/34
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Click the arrows to expand or collapse the folder view, and select the check boxes for the folders you want to
sync.

Choose the sync direction:

• Two-Way
• Remote to Local (default)
• Local to Remote

or
• Select I'll choose the folders to sync later.

8. When the screen displays a success message, click Finish to exit the Account Wizard.

Modifying a Drive Account for Shares
The steps below assume that you have Drive installed and running, and that you have created at least one Drive
account that you want to modify.

To modify a transfer account, do the following:

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Description The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the server.

4. Back in the Preferences dialog, click Save to put into effect any changes you have made.

Transferring Content
Drive is accessible through a Finder-like interface. You can use standard Finder functions for moving and copying
files between the server and your local computer.

1. To access the transfer server, click the Drive icon  in the menu bar, and select Aspera Drive > accountName.
2. Use standard Finder functions for browsing through files and folders of each account, transferring files to and

from your transfer account, or creating new folders.

Note:  Depending on your account's permissions on the file transfer server, you might encounter limitations on the
following actions on the transfer server:

• browsing
• transfers
• file operations
• context menu options

3. Verify the status of your transfer:
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If it is not already open, open the Drive Activity window. On the Transfers pane, in the list of transferred files
and folders, view the status of your transfer.
You can see its status during a transfer, or after it has completed.

The buttons on the Activity window's Transfers pane have the following meanings:

Opens the Transfer Monitor for more in-progress detail about the transfer.

In the Transfer Monitor, you can adjust the transfer rate (if allowed).

Opens a Finder window to the transfer destination folder (the containing folder).

Stops an in-progess transfer.

Resumes a stopped or suspended transfer.

Note:  If a transfer is reported as complete but the file or folder does not appear in the Drive window, refresh the
window.

Synchronization

Understanding Sync
If you are using Aspera Drive with Aspera on Cloud or Aspera Shares, Drive can synchronize files and folders
automatically between the remote server and the local computer.

Sync Direction

When you set up sync, you must choose a sync direction. Aspera Drive can be configured for the following direction
settings:

• remote to local

This is the default setting. In this configuration, the remote computer (usually a server) retains the master version
of the files. The latest content is copied from the server to users' workstations.

• local to remote

In this configuration, the user's version of the content is assumed to be the master version, and is copied to a
central server. Typically, this setting is employed when users update content frequently.

• two-way

In a two-way sync relationship, changes in each location are copied to the other location. With this type of sync,
the contents of both remote and local are identical after the sync has been performed.

To avoid unexpected results, understand what each sync direction setting means and choose carefully. For example,
consider the following scenario:

The system is configured for remote-to-local sync. When the scheduled automatic sync occurs, the latest content is
copied from the remote computer to the user's local desktop. A local user then creates a new file. The next automatic
sync occurs, but this new file still exists only on the user's computer. This is the expected behavior in remote-to-local
sync. In this scenario, the content on the destination is not necessarily identical to that on the source.
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Initial Synchronization

When you first set up a sync relationship between two computers, the system performs its initial transfer of content
from the source location to the destination (or target) location. Depending on the size of the body of content, this can
be a large operation.

Then, when the system performs the next automatic sync, any changes at the source location are copied to the target.

Automatic Sync Versus Reset

Automatic Sync

After the initial transfer, synchronization between the transfer server and client computers occurs automatically, at the
regular interval you have chosen.

In these automatic sync operations, the system transfers only the changes since the most recent sync.

Reset Sync

A reset operation is like starting over. Unlike automatic sync, a reset is a wholesale transfer of all the content, not
just the changed content. Because a reset clears the sync records, you typically perform a reset only after resolving a
conflict or changing the sync configuration.

Sync with Aspera on Cloud
If you are using Aspera Drive with Aspera on Cloud, Drive can synchronize files and folders automatically between
the remote server and the local computer.

Before you begin, ensure that you have the following in place:

• Drive account configuration:

You must have Drive accounts that can synchronize content with your Aspera on Cloud instance.

For more information, see Adding a Drive Account for Aspera on Cloud on page 6.
• Sync configuration in Drive and in Aspera on Cloud:

Pay close attention to the configuration of the sync relationship. In all cases, the settings in Aspera on Cloud
override the settings locally in Drive. Note that if your Aspera on Cloud transfer server nodes are not correctly
configured, you may experience sync problems between Aspera on Cloud and Drive users.

For detailed information, see the  IBM Aspera High-Speed Transfer Server documentation.

Sync with Aspera Shares
If you are using Aspera Drive with a Shares transfer server, Drive can synchronize files and folders automatically
between the remote server and the local computer.

Before you begin, ensure that you have the following in place:

• Server configuration:

In order to set up sync with a Shares server, the server must be configured for sync in its aspera.conf file and must
have the appropriate license.

For further information on your server's configuration file and license, see the  Admin Guide for your Shares
transfer server.

• User permissions in Shares:

Shares users who will use Drive with sync features must be authorized to perform create, delete, and rename file
operations. The Shares admin can set these on the Authorizations tab.

• Drive account configuration:

https://downloads.asperasoft.com/en/downloads/1
https://downloads.asperasoft.com/en/downloads/34
https://downloads.asperasoft.com/en/downloads/34
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You must have Drive accounts that can synchronize content with a Shares server.

For more information, see Adding a Drive Account for Shares on page 18.
• Sync configuration in Drive and in Shares:

Pay close attention to the configuration of the sync relationship. In all cases, the settings on the Shares server
override the settings locally in Drive. Note that if your Shares server is not correctly configured, you may
experience sync problems between the server and Drive users.

For detailed information, see the  IBM Aspera High-Speed Transfer Server documentation.

Configuring Sync in Drive
When you use Drive's synchronization capability, you can configure various aspects of the sync relationship. Start by
selecting Preferences > Accounts.

Selecting Folders to Sync

In most cases, you will have set up sync folders when you added accounts to Drive. But if you opted not to set
up sync with your accounts, or if you need to change the the folders on the transfer server that you want the local
computer to sync with, do the following:

1. On the Accounts pane, select the account for which you want to configure sync folders.
2. On the Services pane, click Sync folder: Settings.

The Sync Settings dialog appears.

Note:  If sync capabilities are made available for the transfer server after the account has been added to Drive, you
must remove and then re-add the account to Drive in order to use the Sync Settings dialog.

3. Select the folders on the remote server that you would like to sync with the local computer.
Browse through the nested folders shown under Synchronize with the selected remote folders, and select the
ones that should be synced with.

4. Set the local path for the sync.
Under Local Folder Path, the default path on the local computer is shown. If you want to change it, click Browse
and navigate to the desired location.

Configuring the Sync Direction

Drive's synchronization between the remote server and the local computer can be upload-only, download-only, or
bidirectional. For a description of these sync direction options and their behavior, see Sync Direction on page 20.

To set the sync direction, do the following:

1. On the Accounts pane, select the account for which you want to configure sync direction.
2. On the Services pane, click Sync folder: Settings.

The Sync Settings dialog appears.

Note:  If sync capabilities are made available for the transfer server after the account has been added to Drive, you
must remove and then re-add the account to Drive in order to use the Sync Settings dialog.

3. In the Direction drop-down list, choose Two-Way, Remote to Local, or Local to Remote.

Resetting the Sync

You can reset the sync at any time; for example when you have changed the sync configuration, or after resolving
a sync conflict. When you reset the sync, your sync configuration settings are retained, but the repositories are
rescanned for discrepancies. To reset the sync, do the following:

1. On the Accounts pane, select the account for which you want to reset the sync.

https://downloads.asperasoft.com/en/downloads/1
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2. On the Services pane, click Sync folder: Settings.
The Sync Settings dialog appears.

Note:  If sync capabilities are made available for the transfer server after the account has been added to Drive, you
must remove and then re-add the account to Drive in order to use the Sync Settings dialog.

3. Select Reset Sync and click OK.

Syncing Content

Monitoring Sync Status

You can monitor the status of a sync operation on the Activity Window > Sync tab.

A progress bar shows in-progress synchronizations, and a countdown timer shows when the next synchronization will
take place.

Stopping and Starting Sync

You can stop and resume file syncing with these buttons on the Activity Window > Sync tab:

Stops an in-progress synchronization.

Resumes a stopped synchronization.

Resolving Sync Conflicts

A sync conflict occurs when the file on one side does not match the file on the other side. Files and folders may not be
synchronized for reasons such as insufficient permissions for the destination folder on the local computer.

If a file or folder cannot be synchronized, a conflict warning appears on the Activity Window > Sync tab.

To resolve the conflict, do the following:

1. Click the red conflict link.
2. In the dialog that appears, select the file or folder that is in a conflict state.
3. Click Resolve Selected Conflicts.

Drive renames the content on the local file system, appending the phrase conflict-mine. For example, the file
log.txt is renamed as log.conflict-mine.txt.

After resolving a sync conflict, you might need to reset the sync. For more information, see #unique_31/
unique_31_Connect_42_resetting_sync.

Working with Cloud Implementations

Adding a Drive Account for Cloud Storage
To set up a transfer account, make sure you have the following information from the system administrator who
manages your transfer server:

• A URL for the transfer server, including a port and path (if applicable).
• A username and password that was set up on your transfer server.

The steps below assume that you have Drive installed and running.
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1.
2. Click  to add a transfer account.

The Account Wizard opens.
3. Fill in the fields with the following information about the transfer server:

Field Description

Account Description The name of the account. The name is used only by Drive.

Server Address The URL address for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.

Click Set up Aspera Drive.
4. Fill in the following information about your cloud storage:

Field Description

Cloud Storage The type of cloud storage. Select either Microsoft Azure or Microsoft Azure
SAS.

Storage account The account name for the cloud storage you will use.

Note:  For Azure SAS accounts, the URL must have been created with full
permissions.

Access key The alphanumeric key for this storage account.

Path The path within the storage that this Drive account should have access to.

Use page blobs Select if your cloud storage uses page blobs.

Click Next.
5. When the screen displays a success message, click Finish to exit the Account Wizard.

Modifying a Drive Account for Cloud Storage
The steps below assume that you have Drive installed and running, and that you have created at least one Drive
account that you want to modify.

To modify a cloud account, do the following:

1. In the menu bar, click the Drive icon  and select Preferences > Accounts.
2. On the left side of the dialog, select the transfer server account you want to modify.
3. Under Account, you can change the connection settings for the account:

Field Description

Description The name of the account. The name is used only by Drive.

Server address The URL for the server, and the port number (if applicable).

Username The username that you have on the transfer server.

Password The password that you have on the transfer server.
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Field Description

Do not verify host's SSL
certificate

If selected, Drive will bypass the validation of your server's SSL certificate.

Select this option if your server's certificate is not valid, but you trust the server.

4. In the Storage area, you can configure these aspects of the account:

Field Description

Storage account The account name for the cloud storage you will use.

Access key The alphanumeric key for this storage account.

Path The path within the storage that this Drive account should have access to.

If you make changes to these fields, Drive then verifies that it can still access the storage. If it cannot, you can
revert to the previous settings.

5. Click OK to put into effect any changes you have made.

Working with Aspera Encrypted Files

Decrypting Packages
Encrypting a file protects it from unwanted access. When an encrypted file arrives after transfer, you must decrypt it
before you can use it.

Note:  Decrypting files requires a passphrase — a sequence of text that the sender of the package used to encrypt the
package. Before decrypting files, ensure that you have the necessary passphrase.

IBM Aspera Crypt works with Drive to decrypt downloaded files.

To decrypt files you have downloaded, do the following:

1. While Drive is running, click the Drive icon  in the menu bar, and select Unlock Encrypted Files.
The Aspera Crypt dialog appears.

2. Select a package or browse to the encrypted content.
When the encrypted content is loaded into Crypt, a status message appears at the bottom of the application,
displaying the number of items ready for decryption.

3. Type the passphrase into the field and click Decrypt.
You can also choose to decrypt the content later.

4. View the output in the Aspera Crypt viewing window.

The decrypted contents appear in the same directory as the original encrypted contents.

If the decrypted file (without the .aspera-env extension) already exists in the same folder, “(decrypted)” is added
to the filename.

If your Aspera Crypt viewing window has multiple decrypted items listed, you can use the View drop-down list
to sort the items by latest, finished, or failed.

Configuring Your Decryption Settings
You can adjust the settings that are used when packages are decrypted. In the Crypt window, do the following:
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1. Click Settings.
2. Configure the following:

• Delete encrypted files when finished

When this check box is selected, Crypt removes the encrypted files from your system after the destination
(decrypted) content has been created.

• Number of concurrent threads for decryption

Select the number of threads that are decrypting at any given time. A higher setting means that files will be
decrypted more quickly, but this may slow down the rest of your computer while it is running. The options are
1 (default), 2, 4 and 8.

Drive Preferences

Setting Your Preferences in Drive
Through the Preferences dialog, you can set your preferences for the following areas:

• general settings
• accounts
• transfers
• network
• bandwidth

To set your preferences, open the Preferences dialog:

With Drive running, click its icon  in the menu bar, and select Preferences.

General Preferences
You can set the following preferences at Preferences > General:

Field Description

Remove transfer list items Select whether to remove the entry automatically from the transfer view after it has
completed, or to manually remove items.

Manually is selected by default.

Logging level Choose the level of information to be recorded in the Drive logs. Options are:

• Info
• Debug
• Trace

Note:  Do not change this setting unless Aspera Technical Support asks you to do
so.

Account Preferences
Select Preferences > Accounts to create, configure, modify, and remove accounts.
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Adding an Account

• For instructions on adding Drive accounts for use with a Shares transfer server, see Adding a Drive Account for
Shares on page 18.

• For instructions on adding Drive accounts for use with a Faspex transfer server, see Adding a Drive Account for
Faspex on page 13.

• For instructions on adding Drive accounts for use with cloud storage, see Adding a Drive Account for Cloud
Storage on page 23.

Modifying an Account

• For Shares, see Modifying a Drive Account for Shares on page 19.
• For Faspex, see Modifying a Drive Account for Faspex on page 14.
• For cloud accounts, see Modifying a Drive Account for Cloud Storage on page 24.

Removing an Account

To remove an account and manage the account's files after removal, do the following:

1. In the list of accounts, select an account to be removed.
2.

Click  to remove the account.

When you remove an account, all account transfers and services associated with that account are stopped and
removed.

3. Click Yes to confirm the account removal, or click No to cancel the account removal.

Configuring Sync Settings

For Drive accounts that are set up with Aspera on Cloud or Shares as the transfer server, you can configure
synchronization settings, such as which remote folders to sync with, and the direction of the synchronization
relationship.

For instructions on setting up and using synchronization features, see Sync with Aspera on Cloud on page 21 and
Sync with Aspera Shares on page 21.

Configuring Faspex Account Settings

For Drive accounts that are set up with Faspex as the transfer server, you can configure the following:

• The local directory for received packages.
• Whether to overwrite packages.
• How often Drive should look for new packages.

For instructions, see Modifying a Drive Account for Faspex on page 14.

If you make any changes on the Accounts pane, click either Revert to undo them,or Save to put them into effect.

Transfer Preferences
Select Preferences > Transfers to set your transfer preferences.

1. Configure settings in the Queue area of the Transfers pane:

Field Description Default
Setting

Enable queuing When this check box is selected, Drive limits the number of
concurrent transfers.

Note:  When transfers are queued, you can start them manually from
the Activity > Transfers window.

Selected
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Field Description Default
Setting

Maximum concurrent
transfers

If Enable queuing is selected, you can enter a maximum number of
concurrent transfers in this field.

Any transfers above this value are queued and then started once the
number of concurrent transfers drops below the specified value.

When queuing is not enabled, this field is not available.

3

2. Configure settings in the Retry area of the Transfers pane:

Field Description Default
Setting

Automatically retry
failed transfers

When this check box is selected, Drive retries failed transfers.

If you want Drive to retry failed transfers, specify the number of
attempts and the interval in which Drive will try to resend in seconds,
minutes, or hours.

Selected

Attempts When Automatically retry failed transfers is selected, Drive will
make the number of retry attempts that you specify in this field.

3

Interval When Automatically retry failed transfers is selected, Drive will
retry transfers at the interval you specify in this field.

30 seconds

3. Configure settings in the Sync area of the Transfers pane:

Field Description Default
Setting

Interval If the sync feature is enabled, specify the interval between
synchronizations.

30 seconds

4. Close the Preferences dialog. Drive saves your settings.

Network Preferences
Select Preferences > Network to set your network preferences.

1. In the HTTP Proxy area, set the following preferences:

Field Description

Use HTTP Proxy If this check box is selected, Drive uses an HTTP proxy to connect to the
Internet.

• Username
• Password
• Address and Port

Use these fields to define your HTTP proxy configuration. Type the following
information:

• your username
• your password
• your server's URL or IP address, and port number

Note:  For some proxies, username and password are optional.

2. If you will use a FASP proxy for your transfers, set the following preferences in the dialog's FASP Proxy area:
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Field Description

Use FASP Proxy (DNAT) If your transfers will use an IBM Aspera FASP Proxy server, select this check
box.

Secure (DNATS) Select this check box if your FASP Proxy uses a secure connection.

• Username
• Password
• Address and Port

Use these fields to define your FASP Proxy configuration. Type the following
information:

• your server username
• your server password
• your server's URL or IP address, and port number

Note:  These fields are enabled only if Use FASP Proxy (DNAT) is selected.

Bandwidth Preferences
Transfer speeds depend on server settings and your network connectivity. To limit transfer rates, do the following:

Select Preferences > Bandwidth and set your bandwidth preferences:

Field Description

Limit Download to When the Limit Download to check box is selected, you can set the download rate
in either megabits per second (Mbps) or kilobits per second (Kbps).

This rate applies to each download.

Limit Upload to When the Limit Upload to check box is selected, you can set the upload rate in
either megabits per second (Mbps) or kilobits per second (Kbps).

This rate applies to each upload.

The Drive Configuration File

Why Use a Configuration File?
You can use Drive with a configuration file that contains all the necessary information on the Drive settings and
accounts for an organization or a workgroup. This practice makes it easy to deploy preconfigured Drive policy
settings to a large group of users: instead of configuring each client workstation manually, you simply load the
configuration file when you install Drive.

Creating a Configuration File
Follow the steps below to ensure that you are creating a configuration file that is correctly defined.

In this process, you will add an account to Drive, and create a configuration file based on that account. But next, so
that you can verify that the configuration file is working, you will delete the account you had created. Then, when you
load the configuration file, you will see the account information correctly represented in Drive.

1. Select Preferences > Accounts to add the account to Drive.
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For instructions, see Adding a Drive Account for Shares on page 18 for a Shares server, or Adding a Drive
Account for Faspex on page 13 for a Faspex server.
When you add the account, also configure any other aspects of it that you want to control, such as:

• the sync directory or download destination directory
• the time interval for checking for transfers
• a passphrase for encrypted packages

2. Once you have added the account, close Drive: Click its icon  in the menu bar, and select Quit.
3. Create a configuration file by typing the following in a terminal window:

/Applications/Aspera\ Drive.app/Contents/MacOS/AsperaDrive -
w configurationFile

For example, the following command creates a configuration file named asperadrive.conf in the user's home
directory:

/Applications/Aspera\ Drive.app/Contents/MacOS/AsperaDrive -w ~/
asperadrive.conf

4. Open the configuration file and edit it as necessary.
For an example, see Sample Configuration File on page 30.

5. Start Drive and go to Preferences > Accounts.
6. Delete the account that you created in Step 1.

Note:  You are deleting the account so that, in the next steps, you can verify that the configuration file is working.
7. Quit Drive.

Note:  You must quit Drive before using the configuration file.
8. Load the account from the configuration file by running the following in a terminal window:

/Applications/Aspera\ Drive.app/Contents/MacOS/AsperaDrive -
f configurationFile

For example:

/Applications/Aspera\ Drive.app/Contents/MacOS/AsperaDrive -f ~/
asperadrive.conf

9. Restart Drive, and verify that the account has been loaded correctly by going to Preferences > Accounts.

You can now use the configuration file to load the account into any Drive installation.

Note:  The account settings that you specify in the configuration file are loaded only for accounts that do not already
exist in Drive. If an account already exists in Drive, or if the configuration file contains settings for an account that
already exists, that account's settings are not changed when the configuration file is loaded.

This disparity is not usually an issue because in most cases, the configuration file is only loaded when Drive is first
installed. However, if you use a configuration file with an existing Drive installation, note the distinction.

Note:  Mac OS X does not use the "preserve_creation_time" setting found in the Drive configuration file.
Downloaded packages do not retain creation time stamps, but will still retain accessed and modified time stamps.

Sample Configuration File
The example below is an excerpt of a configuration file, showing the username and password fields for a user
account.
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For instructions on creating and using a configuration file with Drive, see Creating a Configuration File on page
29.

        { 
            "conf": { 
                "accounts": [ 
                    { 
                        "faspex": { 
                            "auto_start": true, 
                            "check_interval_seconds": 900, 
                            "download_dir": "/Users/jdoe/Documents/
sync1@200_143/Sync Upload Packages 4", 
                            "last_favlink": "/Users/jdoe/Documents/
sync1@200_143/Sync Upload Packages 4", 
                            "name": "DriveFaspexJDoe@201_138 Inbox", 
                            "passphrase": "", 
                            "passphrase_cleartext": "", 
                            "passphrase_enabled": true, 
                            "separate_package_folders": true, 
                            "sequence_id": 34244, 
                            "skip_owner_packages": false, 
                            "start_from": 1404284400000 
                        }, 
                        "host": "https://10.0.201.138", 
                        "name": "DriveFaspexJDoe@201_138", 
                        "password": "e88229c4be15abd2", 
                        "password_cleartext": "", 
                        "storage_host": "", 
                        "storage_password": "", 
                        "storage_password_cleartext": "", 
                        "storage_type": "Default", 
                        "storage_user": "", 
                        "user": "DriveFaspexJDoe" 
                    }, 
                    {
                    .
                    .
                    . 
      

Note:  You may want users to be prompted for credentials when they first launch Drive. To do this, edit your
configuration file to include empty username and password fields as follows:

"password": "", 
"user": ""  

Troubleshooting

Where do I find Drive log files?

In the menu bar, click the Drive icon  and select Open Log Folder.

Alternatively, you can go to ~/Library/Logs/Aspera_Drive.
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How can I reduce the bandwidth that Drive uses?

You can limit the number of concurrent transfers in Preferences > Transfers. You can also limit the amount of
bandwidth used by each transfer in Preferences > Bandwidth. For details, see Transfer Preferences on page 27
and Bandwidth Preferences on page 29.

The system sent me an email notifying me that I've received a package. Why can't I download the
package through my Web browser?

To download transferred packages through a Web browser, you must have the IBM Aspera Connect application
installed on your local computer.

Go to downloads.asperasoft.com/connect2/ and install Connect so that your browser can download packages from the
transfer server.

For more information, see the IBM Aspera Connect User's Guide.

I'm using Drive with a Shares server, but I don't see a way to configure my sync settings.

It may be that Drive needs to re-load sync information for that Shares server or node.

To address this, do the following:

1. Go to Preferences > Accounts.
2. Remove the account.
3. Add the account again so that Drive recognizes the sync capabilities.

The Services pane should now appear.

I'm using SAML authentication, and am having trouble logging in.

When you quit out of Drive and then restart, the system needs to re-authenticate you with the server. So enter your
SAML credentials again when you restart Drive.

Syncing with multiple folders

When your Drive installation is configured with a local-to-remote sync, Drive does not recreate all subfolders of the
selected remote sync directory on the local computer. This is the default behavior, intended to reduce confusion since
you are not interacting with the subfolders.

If you want to sync into the subfolders, make sure to select them individually (effectively setting up multiple sync
relationships).

How can I view thumbnails of video files?

While you can see a preview of image files, and many other file types, in the file browser, Drive does not support
video previews.

Technical Support

Support Websites

For an overview of IBM Aspera Support services, go to https://asperasoft.com/company/support/.

To view product announcements, webinars, and knowledgebase articles, as well as access the Aspera Support
Community Forum, sign into the IBM Aspera Support site at https://www.ibm.com/mysupport/ using your IBMid
(not your company Aspera credentials), or set up a new account. Search for Aspera and select the product. Click
Follow to receive notifications when new knowledgebase articles are available.

https://downloads.asperasoft.com/connect2/
https://downloads.asperasoft.com/en/documentation/8
https://asperasoft.com/company/support/
https://www.ibm.com/mysupport/
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Personalized Support

You may contact an Aspera support technician 24 hours a day, 7 days a week, through the following methods, with a
guaranteed 4-hour response time.

Email aspera-support@ibm.com

Phone (North America) +1 (510) 849-2386, option 2

Phone (Europe) +44 (0) 207-993-6653 option 2

Phone (Singapore) +81 (0) 3-4578-9357 option 2

Legal Notice

© 2012-2013-2014-2016-2017-2018 Aspera, Inc., an IBM Company. All rights reserved.

Licensed Materials - Property of IBM
5725-S575737-A725737-C65
© Copyright IBM Corp. , 20132014,2016,2017, 2018. Used under license.
US Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.

Aspera, the Aspera logo, and FASP transfer technology are trademarks of Aspera, Inc., registered in the United
States. Aspera Connect Server, Aspera Drive, Aspera Enterprise Server, Aspera Point-to-Point, Aspera Client, Aspera
Connect, Aspera Cargo, Aspera Console, Aspera Orchestrator, Aspera Crypt, Aspera Shares, the Aspera Add-in for
Microsoft Outlook, Aspera FASPStream and Aspera Faspex are trademarks of Aspera, Inc. All other trademarks
mentioned in this document are the property of their respective owners. Mention of third-party products in this
document is for informational purposes only. All understandings, agreements, or warranties, if any, take place directly
between the vendors and the prospective users.


	Contents
	Introduction
	Installation
	Installing Drive
	Upgrading Drive
	Uninstalling Drive

	Working with IBM Aspera on Cloud
	Drive with Aspera on Cloud
	Adding a Drive Account for Aspera on Cloud
	Checkin/Checkout of Aspera on Cloud Content
	My Checkouts
	Troubleshooting the Checkin/Checkout Process

	Working with IBM Aspera Faspex
	Drive with Faspex
	Configuring Faspex
	Adding a Drive Account for Faspex
	Modifying a Drive Account for Faspex
	Sending Faspex Packages with Drive
	Receiving Faspex Packages with Drive

	Working with IBM Aspera Shares
	Drive with Shares
	Configuring Shares
	Adding a Drive Account for Shares
	Modifying a Drive Account for Shares
	Transferring Content

	Synchronization
	Understanding Sync
	Sync with Aspera on Cloud
	Sync with Aspera Shares
	Configuring Sync in Drive
	Selecting Folders to Sync
	Configuring the Sync Direction
	Resetting the Sync

	Syncing Content

	Working with Cloud Implementations
	Adding a Drive Account for Cloud Storage
	Modifying a Drive Account for Cloud Storage

	Working with Aspera Encrypted Files
	Decrypting Packages
	Configuring Your Decryption Settings

	Drive Preferences
	Setting Your Preferences in Drive
	General Preferences
	Account Preferences
	Transfer Preferences
	Network Preferences
	Bandwidth Preferences

	The Drive Configuration File
	Why Use a Configuration File?
	Creating a Configuration File
	Sample Configuration File

	Troubleshooting
	Technical Support
	Legal Notice

